Bug 440009 - yum traceback
yum traceback
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-01 07:13 EDT by Rahul Sundaram
Modified: 2014-01-21 18:02 EST (History)
6 users (show)

See Also:
Fixed In Version: 3.2.14-7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-12 14:50:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rahul Sundaram 2008-04-01 07:13:36 EDT
Description of problem:

# rpm -q yum

yum-3.2.13-1.fc9.noarch

# yum search fedora | grep any


Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 236, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 111, in main
    result, resultmsgs = base.doCommands()
  File "/usr/share/yum-cli/cli.py", line 309, in doCommands
    return self.yum_cli_commands[self.basecmd].doCommand(self, self.basecmd,
self.extcmds)
  File "/usr/share/yum-cli/yumcommands.py", line 498, in doCommand
    return base.search(extcmds)
  File "/usr/share/yum-cli/cli.py", line 697, in search
    self.matchcallback(po, matched_value, args)
  File "/usr/share/yum-cli/output.py", line 460, in matchcallback
    print msg
  File "/usr/lib/python2.5/codecs.py", line 303, in write
    data, consumed = self.encode(object, self.errors)
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 66: ordinal
not in range(128)
Comment 1 Seth Vidal 2008-04-08 01:55:39 EDT
can you test yum 3.2.14 in rawhide? If it is still broken, reopen this. I
couldn't make this happen on 3.2.14.
Comment 2 Rahul Sundaram 2008-04-08 02:35:45 EDT
I can. Let me know if you need any further information. 

#  yum -d9 search fedora | grep any

monthly jobs (or anything with a period of n days), on systems that
necessarily optimal for any specific hardware configuration.  However,
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 236, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 111, in main
    result, resultmsgs = base.doCommands()
  File "/usr/share/yum-cli/cli.py", line 309, in doCommands
    return self.yum_cli_commands[self.basecmd].doCommand(self, self.basecmd,
self.extcmds)
  File "/usr/share/yum-cli/yumcommands.py", line 498, in doCommand
    return base.search(extcmds)
  File "/usr/share/yum-cli/cli.py", line 697, in search
    self.matchcallback(po, matched_value, args)
  File "/usr/share/yum-cli/output.py", line 460, in matchcallback
    print msg
  File "/usr/lib/python2.5/codecs.py", line 303, in write
    data, consumed = self.encode(object, self.errors)
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 66: ordinal
not in range(128)
Comment 3 Seth Vidal 2008-04-10 11:45:46 EDT
if you don't do the | grep any

it doesn't error out, does it?
Comment 4 Rahul Sundaram 2008-04-10 12:45:10 EDT
No. It works fine without the grep. 
Comment 6 Rahul Sundaram 2008-04-11 11:54:14 EDT
Makes no difference. 
Comment 7 James Antill 2008-04-11 19:37:50 EDT
 Ok, we're pretty sure this one will fix it and if not there's a config. option
to turn the i18n stuff off now:

http://koji.fedoraproject.org/packages/yum/3.2.14/6.fc9/noarch/yum-3.2.14-6.fc9.noarch.rpm
Comment 8 Rahul Sundaram 2008-04-11 19:48:11 EDT
No. It doesn't fix it. Can you please try it before asking me to test it?
Comment 9 Seth Vidal 2008-04-14 16:29:50 EDT
Rahul,
 The problem is in a couple of the cases we can't duplicate it. :-/

There's a new yum release in koji:

http://koji.fedoraproject.org/packages/yum/3.2.14/7.fc9/noarch/yum-3.2.14-7.fc9.noarch.rpm

please give that one a try.

thanks
Comment 10 Rahul Sundaram 2008-04-15 02:32:02 EDT
Good news. The latest update seems to have fixed the problem. 
Comment 11 Bug Zapper 2008-05-14 04:30:55 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 12 Jeremy Katz 2008-06-12 14:50:31 EDT
Closing based on comment #10

Note You need to log in before you can comment on or make changes to this bug.