Bug 44003 - rhn_register v. 1.3.6-1 ignores LANG
Summary: rhn_register v. 1.3.6-1 ignores LANG
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rhn_register   
(Show other bugs)
Version: 7.1
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-06-08 20:33 UTC by David M. Cook
Modified: 2015-01-07 23:46 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-06 03:55:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David M. Cook 2001-06-08 20:33:57 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.2-2smp i686; en-US; rv:0.9.1)
Gecko/20010607

Description of problem:
When LANG is set, rhn_register continues to use English.


How reproducible:
Always

Steps to Reproduce:
1.export LANG=it_IT
2.rhn_register
3.
	

Actual Results:  Got English messages in dialogs

Expected Results:  Messages in Italian, as was the case for rhn_register 1.3.1

Additional info:

Does not effect 7.1 i386 which is not using 1.3.6.

Comment 1 David M. Cook 2001-06-11 17:25:24 UTC
Ah, it is giving Italian messages on the buttons and in Step 2, but not in the
text of the opening dialogs.

Comment 2 Jay Turner 2001-06-27 11:46:37 UTC
The text in the opening dialog is actually being pulled from server-side.  We
don't have that stuff translated, so that's why its not showing up.
Now, something which is strange is that the buttons ('Yes', 'No', 'Back',
'Next', 'Cancel') are not showing up localized.  This have something to do with
the locales installed on the machine?

Comment 3 Adrian Likins 2001-07-06 03:55:19 UTC
This seems to be working again in the current code. jkt/dcook, can
you verify? It seems to work for me in at least it_IT and de_DE.




Comment 4 Jay Turner 2001-07-06 03:59:26 UTC
Yeah, think we have this nailed now.  The messages as well as the titles on the
pages are coming up localized.  The buttons are not, but as I said, think this
has something to do with the locales which are installed on the machine.


Note You need to log in before you can comment on or make changes to this bug.