Bug 440035 - why do Xen virtual interfaces try and do tx-checksumming?
why do Xen virtual interfaces try and do tx-checksumming?
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen (Show other bugs)
5.1
All Linux
low Severity low
: rc
: ---
Assigned To: Xen Maintainance List
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-01 10:32 EDT by Chris Stankaitis
Modified: 2009-12-14 16:26 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-01 10:39:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Stankaitis 2008-04-01 10:32:53 EDT
Description of problem:

Wondering why Xen's Virtual Interfaces virbr0 vifX.0 and on the Guest OS the vif
which eth0 etc map to have tx-checksumming turned on? given that these are not
actual physical NIC Cards which would/could offload the checksumming from the CPU??

The tx-checksumming was giving us big problems with SSH and FTP to our Xen Guest
and we ultimate had to add an ethtools command to our rc.local to turn it off.

Steps to Reproduce:
1. ethtool -k eth0

see that tx-checksumming  is on

you can see that is is on a virtual interface.

[root@dropbox ~]# cat /etc/modprobe.conf 
alias eth0 xennet
alias scsi_hostadapter xenblk


Expected results:

Since Xen bridge, virtual interfaces, and on guestOS virtual interfaces are not
physical NIC Cards which could legitimately offload the checksumming from the
CPU I would have expected that they would have tx-checksumming off by default.
Comment 1 Daniel Berrange 2008-04-01 10:39:52 EDT
The Xen VIF kernel driver *does* support tx-checksumming, in so much as it will
pass packets straight through to the host NIC for checksumming & fragmentation.
For guest<->guest traffic this allows checksumming/fragmentation overhead to be
avoided entirely. This results in a throughput improvements over > x100.


If you have specific scenarios in which tx checksumming causes problems please
enter a bug providing details of exactly what is broken & the steps to reproduce
the problem.

Note You need to log in before you can comment on or make changes to this bug.