Bug 440046 - Current RHEL bnx2 driver causes install to fail
Current RHEL bnx2 driver causes install to fail
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.1
x86_64 Linux
low Severity low
: rc
: ---
Assigned To: Tony Camuso
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-01 10:42 EDT by Rob Lazzurs
Modified: 2010-11-17 14:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-17 14:11:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Rob Lazzurs 2008-04-01 10:42:11 EDT
Description of problem:

We have many HP DL360 G5 servers however we have noticed with a few recent
systems that they will not network install.  In the anaconda installer when it
tried to bring the ethernet adaptor up for the 3rd time it hangs saying it has
lost link.

Upgrading the bnx2 driver to the latest available from broadcom in the installer
initrd resolved this issue.

Version-Release number of selected component (if applicable):

2.6.18-53.el5

How reproducible:

Dependant on the hardware.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

We could only get this happening on some of our hardware so this may be a bug
with only one chip revision or a combination of a broadcom chip revision and
some other chip revision in the system somewhere.  We can have two HP DL360 G5
servers sitting side by side and one server will experience the issue and the
other won't with exactly the same firmware and even the same network port and cable.

I tried all of the suggest workarounds available for the anaconda network
install, link sleep, ethtool settings, etc and none of these worked.  Only
updating the driver seems to resolve this issue.  I first tried to create a
driver disk to resolve this issue rather than modify the initrd however this did
not work as the network driver was already loaded before it could load the
driver disk.

I have a patched initrd that I can attach to this bug with the updated broadcom
driver if you would find this useful.
Comment 1 Jon Kolstad 2008-06-04 05:12:48 EDT
Same problem seen on new Dell M600 blades.
With the driver in 2.6.9-67.EL anaconda fails to get the network going.

Also upgrading to bnx2-1.7.1d from broadcom resolves the issue

Note You need to log in before you can comment on or make changes to this bug.