Bug 440051 - Crash when editing a file
Crash when editing a file
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: java-1.6.0-openjdk (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Thomas Fitzsimmons
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-01 11:01 EDT by Jesse Keating
Modified: 2013-01-09 22:19 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-11 14:02:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Log file. (89.53 KB, application/octet-stream)
2008-04-01 11:01 EDT, Jesse Keating
no flags Details
Log file from workspace (983.78 KB, text/plain)
2008-04-01 11:11 EDT, Jesse Keating
no flags Details
Fedora Eclipse-bugreport.txt (64.50 KB, text/plain)
2008-04-04 16:49 EDT, Mat Booth
no flags Details
hs_err_pid4647.log (76.75 KB, text/plain)
2008-04-04 16:49 EDT, Mat Booth
no flags Details
Workspace .log (395.67 KB, text/plain)
2008-04-04 16:50 EDT, Mat Booth
no flags Details

  None (edit)
Description Jesse Keating 2008-04-01 11:01:54 EDT
I get this when I edit a file:

#
# An unexpected error has been detected by Java Runtime Environment:
#
#  SIGSEGV (0xb) at pc=0x0000000000eac252, pid=16263, tid=2292048
#
# Java VM: OpenJDK 64-Bit Server VM (1.6.0-b08 mixed mode linux-amd64)
# Problematic frame:
# C  [libc.so.6+0x6a252]  fgets+0x32
#
# An error report file with more information is saved as:
# /home/jkeating/hs_err_pid16263.log
#
# If you would like to submit a bug report, please visit:
#   http://icedtea.classpath.org/bugzilla
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
#


I'm attaching the log file.
Comment 1 Jesse Keating 2008-04-01 11:01:54 EDT
Created attachment 299912 [details]
Log file.
Comment 2 Jesse Keating 2008-04-01 11:11:26 EDT
Created attachment 299913 [details]
Log file from workspace

Here is the log file from my workspace.
Comment 3 Andrew Overholt 2008-04-01 11:32:51 EDT
Lillian/Tom:  JVM bug?
Comment 4 Lillian Angel 2008-04-01 11:37:58 EDT
Yes, looks like it definitely is.
Comment 5 Lillian Angel 2008-04-01 15:23:25 EDT
I am not able to reproduce this on i386 or x86_64. Does it only happen when you
try editing a file?
Comment 6 Jesse Keating 2008-04-01 15:30:12 EDT
Yes, as soon as I double click on something like a .spec file or a .py file I
get the crash.
Comment 7 Mat Booth 2008-04-04 16:48:27 EDT
I am also suffering from this bug. Using File->open and dragging/dropping a file
also triggers it. I am attaching my workspace log, JRE crash dump and BugBuddy
crash report.
Comment 8 Mat Booth 2008-04-04 16:49:14 EDT
Created attachment 301336 [details]
Fedora Eclipse-bugreport.txt
Comment 9 Mat Booth 2008-04-04 16:49:43 EDT
Created attachment 301337 [details]
hs_err_pid4647.log
Comment 10 Mat Booth 2008-04-04 16:50:32 EDT
Created attachment 301338 [details]
Workspace .log
Comment 11 Lillian Angel 2008-04-04 16:55:58 EDT
i am looking into this
Comment 12 Lillian Angel 2008-04-11 10:33:01 EDT
Is this still happening? I cannot reproduce it.
Comment 13 Jesse Keating 2008-04-11 14:02:55 EDT
Sorry, thought I had closed it out.  Not seeing it anymore.

Note You need to log in before you can comment on or make changes to this bug.