Bug 440058 - kickstart file with skipx results in runlevel 5 system
kickstart file with skipx results in runlevel 5 system
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F9PR
  Show dependency treegraph
 
Reported: 2008-04-01 11:27 EDT by Orion Poplawski
Modified: 2008-04-03 15:12 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-03 15:12:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2008-04-01 11:27:01 EDT
Description of problem:

For a long time now I've had "skipx" in the kickstart files of my servers to
select a runlevel 3 (no X) system.  With current rawhide though I end up with a
runlevel 5 system.

Also, "skipx" is not present in the anaconda-ks.cfg file on the installed system.

Version-Release number of selected component (if applicable):
11.4.0.63
Comment 1 Orion Poplawski 2008-04-01 11:27:56 EDT
Hmm, /etc/inittab has:

id:3:initdefault:

so maybe this is an upstart issue?
Comment 2 Chris Lumens 2008-04-03 15:12:38 EDT
anaconda needs to modify /etc/sysconfig/init now, since upstart doesn't look at
/etc/inittab anymore.  This will be fixed in the next build of anaconda.

Note You need to log in before you can comment on or make changes to this bug.