Bug 440082 - NTLMv2 authentication fails
NTLMv2 authentication fails
Status: CLOSED DUPLICATE of bug 427544
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.6
All Linux
low Severity low
: rc
: ---
Assigned To: Jeff Layton
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-01 13:28 EDT by Lenny Maiorani
Modified: 2014-06-18 03:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-03 12:46:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch for kernel 2.6.9-67.0.7 (12.52 KB, patch)
2008-04-01 13:28 EDT, Lenny Maiorani
no flags Details | Diff

  None (edit)
Description Lenny Maiorani 2008-04-01 13:28:30 EDT
Description of problem:
NTLMv2 authentication fails due to improper key signing

Version-Release number of selected component (if applicable):
2.6.9-67 kernels

How reproducible:
Always

Steps to Reproduce:
1. Setup a CIFS share which requires NTLMv2 authentication
2. Try to mount it using a command like: 
mount -t cifs -o username=<username>,sec=ntlmv2i //<hostname>/<dir> <mount_dir>
3. See a failure
  
Actual results:
Authenication fails

Expected results:
Authentication succeeds

Additional info:
The attached patch fixes this issue and only this issue. Please incorporate in
the next RHEL4 update if possible.
Comment 1 Lenny Maiorani 2008-04-01 13:28:30 EDT
Created attachment 299932 [details]
Patch for kernel 2.6.9-67.0.7
Comment 2 Jeff Layton 2008-04-03 09:49:29 EDT
This should already be fixed in the upcoming 4.7 update. If you have a
non-critical place to do so, then please test the kernels on my people page and
let me know whether they resolve the issue for you:

http://people.redhat.com/jlayton

Comment 3 Lenny Maiorani 2008-04-03 12:36:01 EDT
I just tested kernel-smp-2.6.9-68.27.EL.jtltest.34.i686.rpm from that page and
it works as expected. 

Thanks for the quick response.
Comment 4 Jeff Layton 2008-04-03 12:46:36 EDT
Glad to hear it. It should be fixed in 4.7.


*** This bug has been marked as a duplicate of 427544 ***

Note You need to log in before you can comment on or make changes to this bug.