Bug 440083 - /etc/profile.d/alc_env.csh assumes MANPATH is preset
/etc/profile.d/alc_env.csh assumes MANPATH is preset
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: alliance (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Chitlesh GOORAH
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-01 13:32 EDT by Jussi Eloranta
Modified: 2008-07-26 02:08 EDT (History)
0 users

See Also:
Fixed In Version: 5.0-15.20070718snap.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-28 22:36:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jussi Eloranta 2008-04-01 13:32:54 EDT
Description of problem:

With

alliance.x86_64                          5.0-10.20070718snap.fc installed       
alliance.i386                            5.0-10.20070718snap.fc installed  

installed, I get the following message when I login (tcsh as login shell):

MANPATH: Undefined variable.

and my .tcshrc does not get executed when I login. The problem lies in
/etc/profile.d/alc_env.csh which assumes that MANPATH is preset. This script
attempts to add a directory to MANPATH but fails because MANPATH was not set.
One should add a test there to see if MANPATH is already set or not.
This is the line in question:

  setenv MANPATH "${MANPATH}:${ALLIANCE_TOP}/man"

Perhaps, instead:

if ($?MANPATH) then
  setenv MANPATH "${MANPATH}:${ALLIANCE_TOP}/man"
else
  setenv MANPATH "${ALLIANCE_TOP}/man"
endif
Comment 1 Fedora Update System 2008-05-26 17:52:32 EDT
alliance-5.0-15.20070718snap.fc7 has been submitted as an update for Fedora 7
Comment 2 Fedora Update System 2008-05-26 17:53:35 EDT
alliance-5.0-15.20070718snap.fc8 has been submitted as an update for Fedora 8
Comment 3 Fedora Update System 2008-05-26 17:54:53 EDT
alliance-5.0-15.20070718snap.fc9 has been submitted as an update for Fedora 9
Comment 4 Fedora Update System 2008-05-28 22:36:23 EDT
alliance-5.0-15.20070718snap.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Fedora Update System 2008-05-28 22:45:32 EDT
alliance-5.0-15.20070718snap.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2008-07-26 02:08:39 EDT
alliance-5.0-15.20070718snap.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.