Bug 44009 - mounts show as rw in sulogin (emergency) but are only ro
Summary: mounts show as rw in sulogin (emergency) but are only ro
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mount   
(Show other bugs)
Version: 7.1
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-06-09 00:41 UTC by Chip Shabazian
Modified: 2007-04-18 16:33 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-09 00:41:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Chip Shabazian 2001-06-09 00:41:38 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Description of problem:
When you boot into a sulogin mode such as when doing a "linux emergency" 
and run mount, the mounts are displayed with the read-write tag even 
though they are mounted read-only

How reproducible:
Always

Steps to Reproduce:
1.LILO: linux emergency
2.mount
3.
	

Actual Results:  mounts show up as rw but are actually ro

Expected Results:  mount should reports mounts as ro

Additional info:

Comment 1 Bernhard Rosenkraenzer 2002-01-17 19:24:10 UTC
This is  because mount parses /etc/mtab [saved state] rather than /proc/mounts
[current state].
To "fix" this,

rm /etc/mtab
ln -s /proc/mounts /etc/mtab

Please see the mount man page for details on whether or not it's a good idea
(there are both good and bad points about doing this).



Note You need to log in before you can comment on or make changes to this bug.