Bug 440093
| Summary: | Anaconda fails with an unhandled exception installing RH5.1 in Xen vm on a logical volume. | ||||||
|---|---|---|---|---|---|---|---|
| Product: | Red Hat Enterprise Linux 5 | Reporter: | Scott Purcell <scott_purcell> | ||||
| Component: | kernel | Assignee: | Xen Maintainance List <xen-maint> | ||||
| Status: | CLOSED DUPLICATE | QA Contact: | Martin Jenner <mjenner> | ||||
| Severity: | medium | Docs Contact: | |||||
| Priority: | low | ||||||
| Version: | 5.1 | CC: | clalance, dzickus | ||||
| Target Milestone: | rc | ||||||
| Target Release: | --- | ||||||
| Hardware: | x86_64 | ||||||
| OS: | Linux | ||||||
| Whiteboard: | |||||||
| Fixed In Version: | Doc Type: | Bug Fix | |||||
| Doc Text: | Story Points: | --- | |||||
| Clone Of: | Environment: | ||||||
| Last Closed: | 2009-01-22 10:33:57 UTC | Type: | --- | ||||
| Regression: | --- | Mount Type: | --- | ||||
| Documentation: | --- | CRM: | |||||
| Verified Versions: | Category: | --- | |||||
| oVirt Team: | --- | RHEL 7.3 requirements from Atomic Host: | |||||
| Cloudforms Team: | --- | Target Upstream Version: | |||||
| Embargoed: | |||||||
| Attachments: |
|
||||||
|
Description
Scott Purcell
2008-04-01 18:17:23 UTC
Created attachment 299938 [details]
Exception report
Error on attempt to reboot is:
Unable to start virtual machine 'libvirt.libvirtError virDomainCreate() failed
POST operation failed: (xend.err "Error creating domain: Boot loader didn't
return any data!")
Traceback (most recent call last):
File "/usr/share/virt-manager/virtManager/console.py", line 348, in control_vm_run
self.vm.startup()
File "/usr/share/virt-manager/virtManager/domain.py", line 375, in startup
self.vm.create()
File "/usr/lib64/python2.4/site-packages/libvirt.py", line 217, in create
if ret == -1: raise libvirtError ('virDomainCreate() failed', dom=self)
libvirtError: virDomainCreate() failed POST operation failed: (xend.err "Error
creating domain: Boot loader didn't return any data!")
'
There are plenty of kernel error messages at the end of your syslog that point at a hardware or driver error. The following is an excerpt showing some of these messages: <4>lost page write due to I/O error on xvda1 <3>Buffer I/O error on device xvda1, logical block 292 <4>lost page write due to I/O error on xvda1 <3>Buffer I/O error on device xvda1, logical block 293 <4>lost page write due to I/O error on xvda1 <4>end_request: I/O error, dev xvda, sector 2171 <4>end_request: I/O error, dev xvda, sector 107 <4>end_request: I/O error, dev xvda, sector 1137 Okay. I'm trying to identify the cause of the problem. I suspect that there is still a bug here somewhere (maybe in the LVM driver code?). I don't see any indication of problems with the actual storage Hardware -- I can put a filesystem on the same LV and write to it normally with out generating any errors in /var/log/messages. But when I try to use that volume as the storage device for the VM, I get the problem above consistently. Watching /var/log/messages with tail -f during an installation attempt shows the following message (and others differing only in the final numbers): Apr 7 11:26:35 RH5-3G4DKB1 kernel: raid0_make_request bug: can't convert block across chunks or bigger than 256k 507 3 Does this indicate that the bug report should be filed against the kernel? Or are there other things I should investigate? (Forgive me if I'm missing something that should be evident -- I'm not a programmer and not familiar with what I need to do to prepare a full and complete bug report). Seems like a likely candidate for a kernel bug. I'll reassign it and see what they think. This is probably a dup of 223947 (despite the raid10 vs raid0, it looks like the same sort of message). I'm going to close it as such. Chris Lalancette *** This bug has been marked as a duplicate of bug 223947 *** |