This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 440126 - evolution doesn't remember the stat of the message preview
evolution doesn't remember the stat of the message preview
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-01 16:09 EDT by Peter Robinson
Modified: 2008-08-17 08:47 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-17 08:47:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Peter Robinson 2008-04-01 16:09:40 EDT
Evolution doesn't always remember the state of the message preview. It seems it
remembers it in the current session but if I reboot or logout I need to
re-enable it. Everytime after I log back in the preview has gone. Let me know if
you need any more information.

[root@euuklonw7300b1n ~]# rpm -qa| grep evolution
evolution-webcal-2.21.92-1.fc9.x86_64
evolution-2.22.0-4.fc9.x86_64
evolution-data-server-2.22.0-3.fc9.x86_64
evolution-data-server-doc-2.22.0-3.fc9.x86_64
evolution-exchange-2.22.0-1.fc9.x86_64
evolution-data-server-devel-2.22.0-3.fc9.x86_64
evolution-help-2.22.0-4.fc9.x86_64
Comment 1 Matthew Barnes 2008-04-01 19:51:41 EDT
Can you check on a couple GConf keys?

   /apps/evolution/shell/recovery
   /apps/evolution/shell/skip_recovery_dialog

Do you usually exit Evolution before logging out?
Comment 2 Peter Robinson 2008-04-02 05:47:25 EDT
Keys are:
[perobinson@euuklonw7300b1n ~]$ gconftool-2 -g /apps/evolution/shell/recovery
true
[perobinson@euuklonw7300b1n ~]$ gconftool-2 -g
/apps/evolution/shell/skip_recovery_dialog
true

I usually exit evolution before I log out but not always. It tends to be a
matter of how much of a rush I'm in. Sometimes I just type poweroff on a command
line. It always seem to work OK with Fedora 8 whatever I happened to do.
Comment 3 Matthew Barnes 2008-04-02 08:07:14 EDT
Try resetting both of those keys to False.

If Evolution crashes, the next time you restart it will ask you if you want to
turn off previews as a security measure (crashes are often caused by trying to
render an email in the preview pane).  If you elect to skip that dialog in the
future it will always turn off previews automatically when it detects a crash.

Also, I do recall Evolution having issues with session management, such that
closing the session without explicitly closing Evolution first makes Evolution
think it crashed.  I thought this was fixed for Fedora 9, but perhaps not.  I
guess I need to recheck that.
Comment 4 Mike Chambers 2008-06-17 11:03:52 EDT
I have experienced the same thing.  And I am pretty sure it just happens when
evo crashes, or maybe a logout/reboot without closing it.
Comment 5 Peter Robinson 2008-08-17 08:47:11 EDT
This seems to have gone away with later versions of 2.22 even when I have to kill evo because it 'loses connectivity with the exchange backend'. So will close now.

Note You need to log in before you can comment on or make changes to this bug.