Bug 440163 - regression: SCIM is not working properly on Java Swing apps
regression: SCIM is not working properly on Java Swing apps
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: scim (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Jens Petersen
Fedora Extras Quality Assurance
http://sourceforge.net/tracker/index....
: i18n, Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-01 20:48 EDT by Masaki Katakai
Modified: 2008-09-16 19:26 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-16 19:26:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Masaki Katakai 2008-04-01 20:48:38 EDT
Description of problem:

Input method is not working properly on Java application. The reason is that it
seems that the patch

  scim_x11_frontend-ic-focus-LTC27940-215953.patch

has been backed out from Fedora 8.  There is no problem on Fedora 7.

I understand it's a bug in SCIM and I filed an issue against SCIM.
But is there any reason for backing out from Fedora?

Version-Release number of selected component (if applicable):


How reproducible:

See
http://sourceforge.net/tracker/index.php?func=detail&aid=1886959&group_id=108454&atid=650539
for detail.

Steps to Reproduce:
Create Java Swing apps that has input field of dialog. Then start it on Japanese
locale with SCIM/Anthy environment.

1. open dialog
2. CTRL+SPACE
3. input something (ex, nihonn + SPACE)
4. close dialog
5. open dialog
6. CTRL+SPACE
7. input something (ex, nihonn + SPACE)

  
Actual results:

texts are entered into the text field.

Expected results:

The underlined text should not be entered into the text field. It should stay as
uncommitted text. Once users press enter key, it should be committed.

Additional info:
Comment 1 Peng Huang 2008-04-10 02:55:02 EDT
I tested SwingSet2 demo application in 1.6.0_02. I can not reproduce this
problem. Could you test it with jdk 1.6.0_02?
Comment 2 Jens Petersen 2008-04-11 02:04:10 EDT
Could you provide an explicit testcase?
Comment 3 Jens Petersen 2008-04-11 02:06:42 EDT
(In reply to comment #0)
> scim_x11_frontend-ic-focus-LTC27940-215953.patch
> has been backed out from Fedora 8. 

It was removed since it is supposed to be upstream.
Do you think it is still necessary?
Comment 4 Masaki Katakai 2008-04-12 09:26:26 EDT
Thank you Huang and Jens.

Here is the detail test case. I'm using JDK1.6.0_05, it's the latest JDK and
Japanese locale, SCIM/Anthy.

1. download latest JDK (1.6.0_05 from
http://java.sun.com/javase/downloads/index.jsp) and install it

2. verify the path
[test@localhost jfc]$ java -version
java version "1.6.0_05"
Java(TM) SE Runtime Environment (build 1.6.0_05-b13)
Java HotSpot(TM) Client VM (build 10.0-b19, mixed mode, sharing)
[test@localhost jfc]$

3. Start Notepad of demo/jfc
% java -jar demo/jfcNotepad/Notepad.jar

4. Click on icon of "open a file" to invoke file chooser
5. Click on File Name text field
6. ctrl+space to enable input method
7. type something
   characters are still displayed with underline, which means
   it's being composed.
8. Click on Cancel button to dismiss the dialog

9. Try the step 4 to 8 several times (3~5 times)
   At step 7, inputed character should not be entered
   into text field until user press ENTER key, it
   should be displayed with underline. However,
   suddenly, after I repeat 2~3 times, it's entered
   to text field. The underline of the character
   disappears immediately and entered into the text field.
   It should stay with underline as un-committed text.

Comment 5 Masaki Katakai 2008-04-12 09:36:03 EDT
Hi Jens,

(In reply to comment #3)
> (In reply to comment #0)
> > scim_x11_frontend-ic-focus-LTC27940-215953.patch
> > has been backed out from Fedora 8. 
> 
> It was removed since it is supposed to be upstream.
> Do you think it is still necessary?

Yes, I believe so. Is it possible to apply the patch again?

I hope it will be fixed in upstream, however it seems that
there is no activity in upstream, especially for this area -
X11 front end. Because I think X11 front end is not used widely now.
Comment 6 Peng Huang 2008-04-13 23:33:50 EDT
Hi Masaki Katakai,  
I tried many times with jdk 1.6.0_02-b05 , but the problem does not happen. :(
Comment 7 Masaki Katakai 2008-04-14 22:19:53 EDT
Thank you Huang for trying.

OK, I'll check it with 1.6.0_02-b05 but do you have a chance to try the latest JDK?
Comment 8 Peng Huang 2008-04-14 22:37:35 EDT
I have tried the last JDK (build 1.6.0_05-b13) . The problem does not happen too. 
Comment 9 Masaki Katakai 2008-05-01 14:05:13 EDT
Thank you Huang for the testing.

I don't understand the difference with my environment and your environment. It's
always reproducible on my environment for sure.

I have no idea how to provide more information. So I took the movie in flash.

http://mediacast.sun.com/users/MasakiKatakai/media/fedora_bug_440163.swf

You can see the pre-edit text are broken - underline disappears and entered into
the text field.

Comment 10 Jens Petersen 2008-07-16 21:41:51 EDT
Katakai-san, are you still seeing this with Fedora 9?

Thanks for the screencast - unfortunately it appears so small to me
that it is hard for me to see what is going on.
Comment 11 Jens Petersen 2008-07-31 03:16:00 EDT
I think this is my bad.  Not sure why I dropped the patch...
guess I wrongly assumed it was already upstream in 1.4.7.
Comment 13 Jens Petersen 2008-08-26 20:07:24 EDT
I built scim-1.4.7-30.fc10 to address this.

I think we should backport to f9 too.
Comment 14 Fedora Update System 2008-08-28 22:09:03 EDT
scim-1.4.7-24.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/scim-1.4.7-24.fc9
Comment 15 Tony Fu 2008-09-09 23:17:36 EDT
requested by Jens Petersen (#27995)
Comment 16 Fedora Update System 2008-09-10 03:24:16 EDT
scim-1.4.7-24.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update scim'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-7702
Comment 17 Fedora Update System 2008-09-16 19:26:19 EDT
scim-1.4.7-24.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.