This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 440165 - iwl3945: Cannot connect to WPA2 Enterprise network -- works manually.
iwl3945: Cannot connect to WPA2 Enterprise network -- works manually.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-01 20:53 EDT by Ray Van Dolson
Modified: 2008-06-02 16:55 EDT (History)
3 users (show)

See Also:
Fixed In Version: F9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-02 16:55:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Working wpa_supplicant file (when used by hand) (201 bytes, text/plain)
2008-04-01 21:02 EDT, Ray Van Dolson
no flags Details
NetworkManager debug log from connection attempt. (6.14 KB, text/plain)
2008-04-01 21:02 EDT, Ray Van Dolson
no flags Details

  None (edit)
Description Ray Van Dolson 2008-04-01 20:53:45 EDT
I am using a Dell Latitude D620 with the Intel 3945 chipset.  I am able to
connect to my business's WPA2 Enterprise network by hand, ie:

0. Disable NetworkManager
1. Create wpa_supplicant.conf file
2. ifconfig wlan0 up
3. wpa_supplicant -i wlan0 -c /etc/wpa_supplicant/wpa_supplicant.conf
4. iwconfig wlan0 essid "ESSID"
5. dhclient wlan0

However, when using NetworkManager I am not able to get a connection.  It seems
to try for a short while, but returns.  I observe the following behavior:

1. Select WPA2 Enterprise
2. Enter in information and click connect
3. NetworkManager complains about no CA, I click Ignore
4. NetworkManager prompts for access to the keyring.  Although I enter in the
correct password (same on that works with my WEP network at home) it does not
accept it, so I must click Discard to proceed.
5. NetworkManager processes for a while.
6. I am returned to the WPA2 Enterprise information entry dialog.

I am using NetworkManager-0.7.0-0.6.7.svn3235.fc8 in tandem with
kernel-2.6.24.3-34.fc8.
Comment 1 Ray Van Dolson 2008-04-01 20:54:52 EDT
I have tried with and without my "working" wpa_supplicant file ("working" as in
"works" with my by-hand method).  I will attach it along with debug output from
NetworkManager.

This is my first time troubleshooting NetworkManager, so please advise any other
information that would be useful to help track this down.
Comment 2 Ray Van Dolson 2008-04-01 21:02:03 EDT
Created attachment 299997 [details]
Working wpa_supplicant file (when used by hand)
Comment 3 Ray Van Dolson 2008-04-01 21:02:55 EDT
Created attachment 299998 [details]
NetworkManager debug log from connection attempt.

You can see that NM seems to add a few additional options that I don't specify
in my wpa_supplicant.conf file.
Comment 4 Dan Williams 2008-04-02 23:32:35 EDT
Hmm, that "auth2=MSCHAPV2" doesn't look right, I think that's supposed to be
"auth=MSCHAPV2".  Can you try with "auth=MSCHAPV2" in your supplicant config
manually and see if that does anything?  What happens if you remove the phase2
line entirely?

Comment 5 Ray Van Dolson 2008-06-02 13:51:01 EDT
Dan, thanks for your response on this and sorry for the long delay in getting
back to you.

I've upgraded to Fedora 9 where the WPA2 connection now works (mostly) -- well
enough for my needs and I no longer have to initialize the connection manually.

So you can go ahead and close this out.

I will note however, that using the wpa_supplicant.conf I attached worked fine
when manually passed to wpa_supplicant...

Thanks again!
Comment 6 Dan Williams 2008-06-02 16:55:38 EDT
Ok; fixes to NM should filter back to F8 as well but if F9 works, that's great.

Note You need to log in before you can comment on or make changes to this bug.