This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 440167 - iwl4965: kernel upgrade breaks some WPA connections
iwl4965: kernel upgrade breaks some WPA connections
Status: CLOSED DUPLICATE of bug 439249
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-01 21:20 EDT by Bradley
Modified: 2008-04-02 11:09 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-02 11:09:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
iwlist scan (16.65 KB, text/plain)
2008-04-01 21:20 EDT, Bradley
no flags Details

  None (edit)
Description Bradley 2008-04-01 21:20:31 EDT
Description of problem:

After upgrading from kernel-2.6.24.3-12.fc8 to kernel-2.6.24.3-34.fc8 some
wireless connections stop authenticating. (Still broken in kernel-2.6.24.3-50.fc8)

A WPA1 PSK/TKIP connection at home does work, but at university I have a choice
of two APs, one using WPA1/PSK and the other using WPA2 enterprise. Neither work
with the new kernel; both work with the old one. I don't know what the
difference between the two PSK connections is.

Version-Release number of selected component (if applicable):

kernel-2.6.24.3-12.fc8 - works
kernel-2.6.24.3-34.fc8 - fails
kernel-2.6.24.3-50.fc8 - fails

How reproducible:

Always

Steps to Reproduce:
1. Try connecting to my university's APs, using NM
  
Actual results:

Times out, then NM asks for a password

Expected results:

Connects

Additional info:

Scan output from failing kernel is attached. The two SSIDs are 'ASGM2' (PSK) and
'uniwide' (802.1x)

dmesg says (failing kernel):

wlan0: Initial auth_alg=0
wlan0: authenticate with AP 00:02:2d:65:0b:14
wlan0: RX authentication from 00:02:2d:65:0b:14 (alg=0 transaction=2 status=0)
wlan0: authenticated
wlan0: associate with AP 00:02:2d:65:0b:14
wlan0: RX AssocResp from 00:02:2d:65:0b:14 (capab=0x1 status=0 aid=114)
wlan0: associated
wlan0: RX non-WEP frame, but expected encryption
wlan0: Initial auth_alg=0
wlan0: authenticate with AP 00:1e:4a:32:98:15
wlan0: RX authentication from 00:1e:4a:32:98:15 (alg=0 transaction=2 status=0)
wlan0: authenticated
wlan0: associate with AP 00:1e:4a:32:98:15
wlan0: authentication frame received from 00:1e:4a:32:98:15, but not in
authenticate state - ignored
wlan0: Initial auth_alg=0
wlan0: authenticate with AP 00:1e:4a:32:98:15
wlan0: RX authentication from 00:1e:4a:32:98:15 (alg=0 transaction=2 status=0)
wlan0: authenticated
wlan0: associate with AP 00:1e:4a:32:98:15
wlan0: RX AssocResp from 00:1e:4a:32:98:15 (capab=0x431 status=18 aid=0)
wlan0: AP denied association (code=18)
wlan0: associate with AP 00:1e:4a:32:98:15
wlan0: RX AssocResp from 00:1e:4a:32:98:15 (capab=0x431 status=18 aid=0)
wlan0: AP denied association (code=18)
wlan0: associate with AP 00:1e:4a:32:98:15
wlan0: RX AssocResp from 00:1e:4a:32:98:15 (capab=0x431 status=18 aid=0)
wlan0: AP denied association (code=18)
wlan0: association with AP 00:1e:4a:32:98:15 timed out
wlan0: Initial auth_alg=0
wlan0: authenticate with AP 00:19:07:8f:fd:b5
wlan0: Initial auth_alg=0
wlan0: authenticate with AP 00:19:07:8f:fd:b5
wlan0: RX authentication from 00:19:07:8f:fd:b5 (alg=0 transaction=2 status=0)
wlan0: authenticated
wlan0: associate with AP 00:19:07:8f:fd:b5
wlan0: authentication frame received from 00:19:07:8f:fd:b5, but not in
authenticate state - ignored
wlan0: Initial auth_alg=0
wlan0: authenticate with AP 00:19:07:8f:fd:b5
wlan0: RX authentication from 00:19:07:8f:fd:b5 (alg=0 transaction=2 status=0)
wlan0: authenticated
wlan0: associate with AP 00:19:07:8f:fd:b5
wlan0: RX AssocResp from 00:19:07:8f:fd:b5 (capab=0x431 status=18 aid=0)
wlan0: AP denied association (code=18)
wlan0: associate with AP 00:19:07:8f:fd:b5
wlan0: RX AssocResp from 00:19:07:8f:fd:b5 (capab=0x431 status=18 aid=0)
wlan0: AP denied association (code=18)
wlan0: associate with AP 00:19:07:8f:fd:b5
wlan0: RX AssocResp from 00:19:07:8f:fd:b5 (capab=0x431 status=18 aid=0)
wlan0: AP denied association (code=18)
wlan0: association with AP 00:19:07:8f:fd:b5 timed out
Comment 1 Bradley 2008-04-01 21:20:31 EDT
Created attachment 299999 [details]
iwlist scan
Comment 2 John W. Linville 2008-04-02 11:09:17 EDT
I think this is the same as bug 439249...

*** This bug has been marked as a duplicate of 439249 ***

Note You need to log in before you can comment on or make changes to this bug.