Bug 440174 - Better following the package naming to qt
Better following the package naming to qt
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: scim-bridge (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Peng Huang
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F9Target
  Show dependency treegraph
 
Reported: 2008-04-01 22:20 EDT by Akira TAGOH
Modified: 2008-07-08 02:31 EDT (History)
2 users (show)

See Also:
Fixed In Version: F9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-08 02:31:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Akira TAGOH 2008-04-01 22:20:31 EDT
Description of problem:
Currently scim-bridge has -qt for Qt3 and -qt4 for Qt4. recently Qt package has
renamed the package, qt for Qt4 and qt3 for Qt3. I guess it would be better
following that rule to not confuse.

Version-Release number of selected component (if applicable):
0.4.14-1.fc9
Comment 1 Peng Huang 2008-04-01 23:06:55 EDT
fixed in 0.4.15-3
Comment 2 Peng Huang 2008-04-02 19:48:09 EDT
Hi Tagoh, Petersen,

I renamed packages' name of qt & qt4 to qt3 & qt. But yum updating has some
Dependency problems. I added `Obsoletes:      scim-bridge-qt4 <
%{version}-%{release}' in the spec file, but the problem still happens. Do you
have any idea to fix it? I have checked in the new spec file in cvs devel
branch. Please check  it.

I attached the log message below:
[phuang@phuang i386]$ sudo yum -c fedora.repo --disablerepo=rawhide\* install
scim-bridge-qt3 scim-bridge-qt scim-bridge
[sudo] password for phuang: 
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package scim-bridge.i386 1:0.4.15-4.fc9 set to be updated
---> Package scim-bridge-qt3.i386 1:0.4.15-4.fc9 set to be updated
---> Package scim-bridge-qt.i386 1:0.4.15-4.fc9 set to be updated
--> Processing Dependency: scim-bridge = 0.4.15-2.fc9 for package: scim-bridge-qt4
--> Processing Dependency: scim-bridge = 0.4.15-2.fc9 for package: scim-bridge-gtk
--> Running transaction check
---> Package scim-bridge-gtk.i386 1:0.4.15-4.fc9 set to be updated
--> Processing Dependency: scim-bridge = 0.4.15-2.fc9 for package: scim-bridge-qt4
--> Finished Dependency Resolution
scim-bridge-qt4-0.4.15-2.fc9.i386 from installed has depsolving problems
  --> Missing Dependency: scim-bridge = 0.4.15-2.fc9 is needed by package
scim-bridge-qt4-0.4.15-2.fc9.i386 (installed)
Error: Missing Dependency: scim-bridge = 0.4.15-2.fc9 is needed by package
scim-bridge-qt4-0.4.15-2.fc9.i386 (installed)
Comment 3 Bug Zapper 2008-05-14 04:33:31 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.