Bug 44019 - Could not init font path element /usr/share/fonts/default/Type1
Could not init font path element /usr/share/fonts/default/Type1
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-08 23:53 EDT by deniz
Modified: 2007-04-18 12:33 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-04 06:10:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description deniz 2001-06-08 23:53:20 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Description of problem:
When starting X, I get the above message, and the URW fonts are not loaded 
in. Searching the web, I find a similar problem reported on a Mandrake 
list, where they claim that compiling with -fno-force-mem resolves the 
issue. I have not tried this fix. This problem occurs in Redhat 7.1, urw-
fonts package. Below is the fragment reported on the similar Mandrake 
issue.



>> It seems there are at least two problems with the fonts that add up 
>> to the uglyness:
>> - Type 1 rendering is far worse than it used to be. Running 'xset +fp
>>   /usr/share/fonts/default/Type1' mostly reproduces the problems on a 
>>   Mandrake 7.2 system, but the fonts still don't look /that/ bad.

>This problem is caused by an actual bug in the type 1 font loading.
>When compiling XFree86 (tested 4.0.2, 4.0.3 and 4.0.99) with 
>gcc-2.96-0.48mdk, you have to give the flag '-fno-force-mem' in
>RPM_OPT_FLAGS. No problems with gcc-2.95.2 or egcs-1.1.2-44mdk.



How reproducible:
Always

Steps to Reproduce:
1.rpm -Uvh urw-fonts*
2.startx
3.check /var/log/XFree86.0.log or do xlsfonts and look for fonts in the 
URW package.
	

Actual Results:  no URW fonts, 
end of XFree86.0.log shows: 

Could not init font path element /usr/share/fonts/default/Type1

Expected Results:  should have gotten URW fonts.



Additional info:
Comment 1 Ngo Than 2001-06-15 18:29:48 EDT
It's not a bug in urw-fonts
Comment 2 Jeremy Sanders 2001-07-04 06:10:42 EDT
RH7.1 by default doesn't load the type1 module with XFree86-4. See the section
from my XF86Config-4 file below:


Section "Module"
...
	# Load  "freetype"	 # TrueType font handler
	# Load  "type1"		# Adobe Type 1 font handler
EndSection


It relies on xfs to render the fonts. This means that type1 fonts can't be added
using a xset +fp line (unless the comment is removed in the XF86Config file).

This also means that apps which load their own type1 fonts break (eg StarOffice,
abiword).
Comment 3 Mike A. Harris 2002-01-25 02:29:13 EST
Running XFree86 4.1.0-3 to test this problem, in RHL 7.1, and also in
RHL 7.2, I am not able to reproduce it, so I presume if there was an
actual bug, that it has been long since fixed.  I am using a more or
less default XFree86 install, and using the xfs font server alone.
The X server is not serving fonts - the only thing in the font path
is xfs's socket.

xfontsel allows me to choose the URW fonts, and displays them in the
test area.  We've just released XFree86 4.1.0-15 as erratum for
RHL 7.1 and 7.2, so I'm closing this bug as fixed in errata.

Note You need to log in before you can comment on or make changes to this bug.