This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 440190 - PackageKit deadlocks with two concurrent installs
PackageKit deadlocks with two concurrent installs
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Robin Norwood
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F9PKBlocker
  Show dependency treegraph
 
Reported: 2008-04-02 02:13 EDT by Jeremy Fitzhardinge
Modified: 2008-04-15 12:53 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-15 12:53:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
pk-update-exception.png (475.61 KB, image/png)
2008-04-03 03:18 EDT, Andrew Farris
no flags Details
rpmdb broken after install failure (42.91 KB, image/png)
2008-04-03 03:20 EDT, Andrew Farris
no flags Details
PK-multiple-refresh-ops-2.png (254.91 KB, image/png)
2008-04-03 03:22 EDT, Andrew Farris
no flags Details
in git (20.81 KB, image/png)
2008-04-11 11:18 EDT, Richard Hughes
no flags Details

  None (edit)
Description Jeremy Fitzhardinge 2008-04-02 02:13:30 EDT
Description of problem:
When using pk-application, deadlock occurs when doing two installs

Version-Release number of selected component (if applicable):
PackageKit-0.1.10-1.fc9.i386
gnome-packagekit-0.1.10-1.fc9.i386


How reproducible:


Steps to Reproduce:
1. start pk-application
2. install "BackupPC"
3. install "cabextract"
  
Actual results:
Hang.  pk-update-icon shows:
Installing BackupPC (installing)
Installing cabextract (waiting for other tasks to complete)
Getting description BackupPC (waiting for other tasks to complete)

Expected results:
Both installs to complete successfully.

Additional info:
Comment 1 Richard Hughes 2008-04-02 05:17:26 EDT
Do the two installs complete eventually?
Comment 2 Jeremy Fitzhardinge 2008-04-02 10:12:37 EDT
No, at least not before I rebooted about 30 mins later.  The BackupPC RPM is in
/var/cache/yum/packages/rawhide, but there's no sign of cabextract.
Comment 3 Jeremy Fitzhardinge 2008-04-02 12:59:45 EDT
I'm doing an update at the moment (~60 packages).  The pk applet is just showing
"updating package audit-libs (downloading)" - and has been for some time. 
However it appears it's actually downloading all the packages, since the network
is busy and they're appearing in /var/cache/yum/rawhide/packages.

I wonder if BackupPC had a number of dependent packages which it was
downloading, but I was confused because there was no indication that was happening.

In other words, perhaps this bug should be something along the lines of
"packagekit applet should show incremental progress during updates/installs".
Comment 4 Andrew Farris 2008-04-03 03:15:30 EDT
I'm seeing something similar with PK trying to get update information 4 times at
once.  Just before this I had an install fail to complete like above comments,
then rebooted, checked my rpmdb which was corrupt (screen to come) and had to do:
rm /var/lib/rpm/__db*; rpm --rebuilddb

Afterward, I'm seeing these multiple operations occur at once.  I did an update
manually via Update System, but as soon as it completed I clicked the Refresh
Info button and it never completed.  The 4 copies of refresh were found then as
the UI was stuck.
Comment 5 Andrew Farris 2008-04-03 03:18:28 EDT
Created attachment 300183 [details]
pk-update-exception.png

Update error, exception during manually requested update operation.
Comment 6 Andrew Farris 2008-04-03 03:20:34 EDT
Created attachment 300184 [details]
rpmdb broken after install failure
Comment 7 Andrew Farris 2008-04-03 03:22:37 EDT
Created attachment 300185 [details]
PK-multiple-refresh-ops-2.png

Showing refresh operations attempting to happen at once, I tried canceling
these by opening each and selecting cancel one at a time, but none of them
managed to stop.  The VM eventually locked up completely.
Comment 8 Andrew Farris 2008-04-07 18:31:06 EDT
I'm seeing this issue continue on both i686 and x64 where about once a day I get
operations hanging (both yum and packagekit) due to the corrupted __db.xxx
files.  Removing them temporarily fixes the problem but it keeps returning.
Comment 9 Andrew Farris 2008-04-07 18:48:07 EDT
I cloned this as a separate bug since its a different issue than original report
and I should have started a new one in the first place.  PK does do some updates
fairly slowly but I think its a mirror selection problem for me when that
happens (no fastestmirror plugin yet).  Sorry for the spam with the two bugs though.
Comment 10 Richard Hughes 2008-04-11 11:18:30 EDT
Created attachment 302135 [details]
in git

Jeremy, we've added UI like this to show you when we have to add new deps to a
transaction to allow it to download. Would this solve your bug?
Comment 11 Jeremy Fitzhardinge 2008-04-11 12:09:39 EDT
It would certainly give more information to distinguish between an unexpectedly
large install (due to dependencies), and an actual hang.
Comment 12 Richard Hughes 2008-04-15 12:53:30 EDT
Marking as fixed, as the status of this bug is unclear, and the original big has
been fixed. Please open a specific bug if you think there is still a problem.
Thanks.

Note You need to log in before you can comment on or make changes to this bug.