Bug 440209 - PCMCIA card correctly named, no driver loaded
PCMCIA card correctly named, no driver loaded
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-02 05:58 EDT by Anne
Modified: 2009-07-14 14:04 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-14 14:04:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Commands output (84.06 KB, text/plain)
2008-04-21 09:25 EDT, Anne
no flags Details

  None (edit)
Description Anne 2008-04-02 05:58:08 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.5; Linux) KHTML/3.5.4 (like Gecko)

Description of problem:
system-config-network, on the hardware tab, shows Netgear FA411 Fast Ethernet 
on device eth0, Status OK.  'Activate' brings '3c501 device eth0 does not seem 
to be present, delaying initialization'.

Version-Release number of selected component (if applicable):
Fedora 9 KDE Live CD installed

How reproducible:
Always


Steps to Reproduce:
1.No special steps, just presence of Netgear PCMCIA card.
2.
3.

Actual Results:
See above

Expected Results:
eth0 activated

Additional info:
The card has been previously used with FC6 and Mandriva 2008.
Comment 1 Harald Hoyer 2008-04-02 06:03:30 EDT
should be fixed in system-config-network-1.5.5
Comment 2 Anne 2008-04-17 12:11:59 EDT
I regret that I am unable to test this.  I have put the necessary package onto
the laptop, but cannot get it installed.  I suspect that the spec of the laptop
is just too low to be able to run anything at all.  Apologies that I can't do
the test.
Comment 3 Anne 2008-04-20 06:48:30 EDT
I finally managed to install system-config-network-1.5.6.  Unfortunately this
has not solved the problem.  I still see '3c501 device eth0 does not seem to be
present, delaying initialization'.  This is, of course, not the correct
hardware.  Is it expected that one of the PCMCIA drivers listed would work with
the Netgear FA411?  I'm experimenting, but it's a very slow process on this old
hardware.
Comment 4 Anne 2008-04-20 12:25:43 EDT
I returned to the LiveCD.  This time I used the nm-applet (plug icon in panel)
to set up the connection.  The hardware was correctly identified, and after
configuring the static IP the connection worked.

The question, then, is why did that work, yet trying to do the same thing on the
hard drive install tells me that no devices were found?
Comment 5 Harald Hoyer 2008-04-21 03:07:08 EDT
what is in /etc/modules.conf ? Any "alias eth0 " ??
Comment 6 Anne 2008-04-21 05:20:54 EDT
There is no /etc/modules.conf.  There is a modprobe.conf but it is empty.
Comment 7 Harald Hoyer 2008-04-21 08:34:06 EDT
sry, yes, modprobe.conf... 

what does:

# /sbin/lspci
# /sbin/lshal
# /sbin/ifconfig -a
# /sbin/ethtool -i eth0

output?

Comment 8 Anne 2008-04-21 09:25:05 EDT
Created attachment 303144 [details]
Commands output
Comment 9 Anne 2008-04-25 15:54:02 EDT
I created a local repo with the rpms from the Preview DVD, then updated. 
Unfortunately I see no improvement whatsoever.  At this stage I can't think of
anything more I can do, unless specifically instructed.

My question stands.  Why could the LiveCD recognise and use the card?
Comment 10 Harald Hoyer 2008-04-27 05:18:31 EDT
/sbin/ethtool -i eth0
Cannot get driver information: No such device

seems like the kernel does not have a driver/module for your device.

udi = '/org/freedesktop/Hal/devices/pcmcia__1__1'
  info.parent = '/org/freedesktop/Hal/devices/pci_1217_6832_0'  (string)
  info.product = 'FA411'  (string)
  info.subsystem = 'pcmcia'  (string)
  info.udi = '/org/freedesktop/Hal/devices/pcmcia__1__1'  (string)
  info.vendor = 'NETGEAR'  (string)
  linux.hotplug_type = 2  (0x2)  (int)
  linux.subsystem = 'pcmcia'  (string)
  linux.sysfs_path = '/sys/devices/pci0000:00/0000:00:0c.1/1.0'  (string)
  pcmcia.card_id = 49579  (0xc1ab)  (int)
  pcmcia.func_id = 6  (0x6)  (int)
  pcmcia.manf_id = 329  (0x149)  (int)
  pcmcia.prod_id1 = 'NETGEAR'  (string)
  pcmcia.prod_id2 = 'FA411'  (string)
  pcmcia.prod_id3 = 'Fast Ethernet'  (string)
  pcmcia.product = 'NETGEAR'  (string)
  pcmcia.socket_number = 1  (0x1)  (int)
  pcmcia.vendor = 'NETGEAR'  (string)

Comment 11 Anne 2008-04-27 06:03:01 EDT
While running the LiveCD with an active connection I found that pcnet_cs was
being used.  However, although I have modprobed that module (confirmed by lsmod) 
pcnet_cs        38704   0
8390    11776   1 pcnet_cs

I haven't so far got it to work.  I shall be away for the next two weeks, so if
any test are required I only have a few more hour to do them.
Comment 12 Bug Zapper 2008-05-14 04:34:16 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 13 Bug Zapper 2009-06-09 19:58:23 EDT
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 14 Bug Zapper 2009-07-14 14:04:13 EDT
Fedora 9 changed to end-of-life (EOL) status on 2009-07-10. Fedora 9 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.