Bug 44021 - hangs on warm reboot
hangs on warm reboot
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-06-09 03:17 EDT by Marco Bertola
Modified: 2007-04-18 12:33 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2003-06-08 16:47:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Marco Bertola 2001-06-09 03:17:10 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2-2 i586)

Description of problem:
The machine (Compaq Presario 1255, AMD K6-2, 333Mhz 64mb) hangs AFTER a
warm reboot.
I.E. the kernel stops everything, no errors are encountered. After the
Please standby.[...]
the screen goes blank (as normal) but then the graphic lilo is spoiled
(black dots everywhere).  After 2-3 secs. the machine starts loading the
kernel, the console is also spoiled (strange characters) and freezes
shortly after writing 
Booting kernel [or whatever, I don't remember].
The only solution is a hard boot.

I have tried to pass the options reboot=c (and also h,b,w) but no changes.
The problem occurs when rebooting from any runlevel (i.e. it is not a X
problem, should be the kernel).
Unfortunately there are no error messages in any of the logs.

How reproducible:

Steps to Reproduce:
1.Turn on
2.Log in as root
3.shutdown -r now (or ctrl+alt+del at any stage)

Actual Results:  The machine hangs AFTER reboot.

Additional info:
Comment 1 Arjan van de Ven 2001-06-09 06:30:30 EDT
This sounds like a bios bug.
Could you try passing "apm=realmode" to the lilo prompt of the "first" boot (eg
the boot where you type reboot) ?

Comment 2 Marco Bertola 2001-06-11 01:09:37 EDT
I tried the suggestion apm=realmode but no difference.
I have recompiled disabling the kernel hacking options (Memory mapper I/O
debugging and Magic SysRq Key)  and the result are somewhat encouraging and

1) Now the new kernel can safely warm reboot (wreboot) from runlevel 1 BUT NOT
runlevel 3.
2) For some reason (!!?) now also the old kernel can reboot from runlevel 1 (and
not from runlevel 3 or higher). Maybe the bug is in some module.
Did I do correctly? 
make mrproper; make menuconfig (using
/usr/src/linux2.4/config/kernel-2.4.2.i586.config); make
dep; make bzImage; make modules; make modules_install, copy the image in
/boot/mykernel, added to lilo.conf,  lilo.
For some strange reason it still complained about unresolved symbols until I
copied /usr/src/linux-2.4/System.map  in /boot/System.map.mykernel and changed
the symlink; but this is never told in any howto (maybe I am confused; but I am
no geek, I just read the howtos!).

3) I tried to enter Interactive mode and excluding everything I seem to be able
to wreboot (both kernels).
4) I tried to exclude only apmd but doesn't solve.
[5) For information, even if I abort installation from cdrom at any early stage
and wreboot, the problem persists.]

Very depressing.
Thanks anyway 

(I'll probably revert to 7.0 because also rp3 doesn't work as it should; 
maybe is only my impression but I get more problems with the latest
distributions (from 5.1 on)) 
Comment 3 Alan Cox 2003-06-08 16:47:57 EDT
Closing out as a BIOS issue, not something we could fix

Note You need to log in before you can comment on or make changes to this bug.