Bug 440228 - SELinux complains about system-config-network
SELinux complains about system-config-network
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: system-config-keyboard (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Lubomir Rintel
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-02 08:47 EDT by Pierre-Yves
Modified: 2009-01-07 13:10 EST (History)
0 users

See Also:
Fixed In Version: 1.2.14-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-07 04:13:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Pierre-Yves 2008-04-02 08:47:13 EDT
Description of problem:
SELinux complains about system-config-keyboard.
I start system-config-keyboard, select my keyboard layout (us international)
enter ok
SELinux returns a denial saying:
SELinux is preventing the loadkeys from using potentially mislabeled files (./tmp). 

So I did
restorecon -R -v '/tmp'

But when I restart system-config-keyboard I still get this denial.


Version-Release number of selected component (if applicable):
system-config-keyboard-1.2.14-1.fc9.noarch
selinux-policy-3.3.1-26.fc9.noarch


How reproducible:
always

Steps to Reproduce:
1.start system-config-keyboard
2.select a map
3.press the button ok
  
Actual results:
SELinux denials

Expected results:
A quiet SELinux

Additional info:
Comment 1 Fred New 2008-04-07 04:02:20 EDT
I used to see SELinux problems with system-config-keyboard, but that has stopped
with recent updates.  I currently have

system-config-keyboard-1.2.14-2.fc9.noarch
selinux-policy-3.3.1-28.fc9.noarch

and I don't get any SELinux notices.  I believe the previous version of
system-config-keyboard was okay with SELinux, too, but I have other problems
with it: bug 437290.
Comment 2 Pierre-Yves 2008-04-07 04:13:30 EDT
Indeed it seems to be solved in the later version.

Thanks to let me know, I close the bug.

Note You need to log in before you can comment on or make changes to this bug.