Bug 44027 - gtali segfaults, works fine when I move the ~/.gnome/gtali file out of the way
Summary: gtali segfaults, works fine when I move the ~/.gnome/gtali file out of the way
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: gnome-games (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jonathan Blandford
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-06-09 13:53 UTC by Bill Crawford
Modified: 2013-04-02 04:15 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-11 14:57:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
.gnome/gtali config/settings file which appears to trigger a segfault in gtali (333 bytes, text/plain)
2001-06-09 14:08 UTC, Bill Crawford
no flags Details

Description Bill Crawford 2001-06-09 13:53:52 UTC
Basically gtali was segfaulting every time on startup (the main window
never appeared, just the "a fault occurred" popup).  I renamed the
config/settings file out of the way and it started up OK.

I'm attaching in a moment the file that was there.

Comment 1 Bill Crawford 2001-06-09 14:08:57 UTC
Created attachment 20694 [details]
.gnome/gtali config/settings file which appears to trigger a segfault in gtali

Comment 2 Bill Crawford 2001-06-09 14:10:24 UTC
Nearly forgot:

[bill@localhost bill]$ gtali --version
Gnome gtali 1.4.0.1
<pre>
[bill@localhost bill]$ rpm -qf $( which gtali )
gnome-games-1.4.0.1-1
[bill@localhost bill]$ rpm -qi gnome-games
Name        : gnome-games                  Relocations: (not relocateable)
Version     : 1.4.0.1                           Vendor: Red Hat, Inc.
Release     : 1                             Build Date: Fri 20 Apr 2001 16:18:33
BST
Install date: Sun 03 Jun 2001 03:16:52 BST      Build Host:
porky.devel.redhat.com
Group       : Amusements/Games              Source RPM:
gnome-games-1.4.0.1-1.src.rpm
Size        : 8452013                          License: LGPL
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
URL         : http://www.gnome.org
Summary     : GNOME games.
Description :
The gnome-games package includes games for the GNOME GUI desktop
environment, including GnomeScott, ctali, freecell, gataxx, glines,
gnibbles, gnobots2, gnome-stones, gnomine, gnotravex, gtali, gturing,
iagno, mahjongg, same-gnome, and sol.
</pre>


Comment 3 Jonathan Blandford 2001-08-03 23:46:14 UTC
This appears to be a somewhat corrupted file.  I'm not sure how it got this way
(I cannot reproduce it.)  In addition, in the future we're moving to a GConf
based config scheme for GNOME, and that will hopefully avoid these problems.


Note You need to log in before you can comment on or make changes to this bug.