Bug 440295 - I/O error : Attempt to load network entity http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd
I/O error : Attempt to load network entity http://www.oasis-open.org/docbook/...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: Virtualization_Guide (Show other bugs)
5.2
All Linux
low Severity low
: rc
: ---
Assigned To: Christopher Curran
Don Domingo
: Documentation, Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-02 13:32 EDT by Milan Zazrivec
Modified: 2009-08-20 00:02 EDT (History)
3 users (show)

See Also:
Fixed In Version: RHBA-2008-0433
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 12:53:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milan Zazrivec 2008-04-02 13:32:56 EDT
Description of problem:
RHEL5.2-Server-20080402.nightly installation produces multiple installation
errors when installing gnome-applet-vm 0.1.2 1.el5. Mentioned errors are of
two kinds:

I/O error : Attempt to load network entity
http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd

and 

5.2/Concept_Configuring_for_Use_on_a_Network.xml:26: parser error : Entity
'mdash' not defined
Comment 3 Milan Zazrivec 2008-04-02 14:30:00 EDT
Mentioned problem was not present in RHEL5.2-Server-20080401.nightly
Comment 6 Milan Zazrivec 2008-04-03 05:24:51 EDT
I think the error occurs when gnome-applet-vm calls /usr/bin/scrollkeeper-update
in its postin section.

All the files that the installation complains about
(/usr/share/doc/Virtualization-en-US-5.2/*)
come from Virtualization-en-US package.
Comment 8 Christopher Curran 2008-04-03 22:10:49 EDT
The tag is a valid entity so it's not an error on my side. I can however hack
around it if there is no other fix available. The problem apparently should have
been fixed with the OMF regression I heard.
Comment 9 Milan Zazrivec 2008-04-04 07:10:01 EDT
Christopher, do you have any advice about what the problem here is or
what component should this bugzilla go to? Are the error messages produced
when calling scrollkeeper-update?

I certainly don't want this bugzilla to sit in the wrong place.
Thanks.
Comment 11 Milan Zazrivec 2008-04-07 08:43:46 EDT
OK, those error messages occur when a package calls scrollkeeper-update
for the first time. I'm not sure why those errors occur though :-(
Comment 12 Jeff Fearn 2008-04-07 17:24:32 EDT
Three things combine to lead to this error:

1. RH Docs use DocBook 4.5
2. RHEL 5 does not ship DocBook 4.5 DTD
3. Scroll Keeper disables network lookup

OMF files have been removed from the latest builds so this problem should be
solved. Virtualization 5.2-8 should be a good build of this book.

Cheers, Jeff.
Comment 16 Milan Zazrivec 2008-04-09 08:13:00 EDT
The error can be easily reproduced:
1) rhel5.2 installation with @base Virtualization-en-US scrollkeeper included
2) after the installation, run scrollkeeper-update and you'll get the same error
messages
3) if you run scrollkeeper-update one more time, it exits without errors
Comment 19 Brock Organ 2008-04-14 17:19:45 EDT
this error, still present in the RHEL5.2-Server-20080414.nightly ...

http://hank.test.redhat.com/kate/auto.cgi?action=case&group=nightly_RHEL5.2-Server-20080414.nightly_5-i386&case=key-server-virtplatform-distill-french-http-TUI-49af-8941-4d14-7589

is using the Virtualization-*-5.2-8 packages, so I think this bug is still open ...
 
Comment 20 Jeff Fearn 2008-04-16 19:06:53 EDT
Mike, I pushed Virtualization-5.2-9 in to brew. Please update the errata.
Comment 23 Milan Zazrivec 2008-04-22 05:23:03 EDT
Verified with Virtualization-5.2-9 / RHEL5.2-Server-20080422.nightly
Comment 24 Satyabrata Maitra 2008-04-30 07:40:27 EDT
Tested it on Proposed version of V-G package, found no error. Its Fixed
now.

Version Tested :
Virtualization-*-5.2-9
gnome-applet-vm-0.1.2.1.el5

OS - RHEL-5.2-Server Beta
Comment 28 errata-xmlrpc 2008-05-21 12:53:54 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0433.html

Note You need to log in before you can comment on or make changes to this bug.