Bug 440297 - FTBFS gcin-1.3.9-2.fc9
FTBFS gcin-1.3.9-2.fc9
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gcin (Show other bugs)
9
All Linux
low Severity high
: ---
: ---
Assigned To: Chung-Yen Chang
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
: i18n, Reopened
Depends On:
Blocks: FTBFS
  Show dependency treegraph
 
Reported: 2008-04-02 13:45 EDT by FTBFS
Modified: 2008-07-08 00:35 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-08 00:35:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description FTBFS 2008-04-02 13:45:29 EDT
gcin-1.3.9-2.fc9.src.rpm Failed To Build From Source
Comment 1 Chung-Yen Chang 2008-04-02 20:43:48 EDT
This build should be OK.

testing if you have QT_IM_MODULE dir:/usr/lib/qt3/plugins/inputmethods support
testing if you have QT_IM_MODULE dir:/usr/lib/qt-3.3/plugins/inputmethods support
testing if you have QT_IM_MODULE dir:/usr/lib/qt-4/plugins/inputmethods support
-> No, you don't have

Check your gcin spec file: (there is a little change)

BuildRequires:  qt3-devel, gtk2-devel, desktop-file-utils

*NOT*
BuildRequires:  qt-devel, gtk2-devel, desktop-file-utils

Comment 2 Caius Chance 2008-04-02 20:50:43 EDT
Build alright on Koji:

http://koji.fedoraproject.org/koji/buildinfo?buildID=37096

NOTABUG.
Comment 3 FTBFS 2008-04-02 21:46:46 EDT
Sorry, my script was supposed to upload the build.log attachment, but that
failed.  I'll fix the script.  But until then, it did indeed fail with a missing
file.

Processing files: gcin-debuginfo-1.3.9-2.fc9
Provides: im-gcin.so.debug libgcin-im-client.so.1.0.2.debug
Requires(rpmlib): rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
Requires: libgcin-im-client.so.1
Checking for unpackaged file(s): /usr/lib/rpm/check-files
/var/tmp/gcin-1.3.9-2.fc9-root-mockbuild
RPM build errors:
    File not found:
/var/tmp/gcin-1.3.9-2.fc9-root-mockbuild/usr/lib/qt-3.3/plugins/inputmethods/libqgcin.so
Comment 4 Chung-Yen Chang 2008-04-02 21:58:58 EDT
It looks like you lack qt library.

please check:
$ rpm -qa |grep qt
$ uname -a
Comment 5 Jens Petersen 2008-04-11 01:57:08 EDT
Yes, but you didn't build the fix yet....
hence builds from cvs but not from current srpm in rawhide.
Comment 6 Bug Zapper 2008-05-14 04:35:44 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Matt Domsch 2008-07-08 00:35:02 EDT
builds as of 2008-07-03, version 1.4.2-2.fc10.

Note You need to log in before you can comment on or make changes to this bug.