Bug 4403 - Installer sets up wrong /etc/lilo.conf
Installer sets up wrong /etc/lilo.conf
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.0
All Linux
medium Severity high
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-08-06 14:11 EDT by lars
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-08-16 14:57:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description lars 1999-08-06 14:11:21 EDT
The installer sets up /etc/lilo.conf pointing to the full path of the kernel image instead of using the /boot/vmlinuz symlink.
The kernel RPMs however only upgrade the symlink, resulting in updated kernels leading to a failed system since the old kernel rpm gets removed when during a -U.
Comment 1 Jay Turner 1999-08-16 14:57:59 EDT
Refer to the kernel-HOWTO for the correct instructions for upgrading
the kernel.  In the process of upgrading the kernel, you will want to
modify the /etc/lilo.conf file to point to the new kernel image as
well as to the old kernel image so that you can safely recover if
there are problems with the new kernel.

Note You need to log in before you can comment on or make changes to this bug.