Bug 440328 - pup fights with packagekit for yum access and updates
pup fights with packagekit for yum access and updates
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F9Blocker
  Show dependency treegraph
 
Reported: 2008-04-02 16:19 EDT by Jesse Keating
Modified: 2013-01-09 22:19 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-12 17:18:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jesse Keating 2008-04-02 16:19:30 EDT
pirut (and thus pup) are still available in rawhide, and upgrading from F8 to
rawhide will bring in the packagekit stack, due to system-install-packages
moving and the need of system-config-printers on it.  What the user ends up with
is both pup and packagekit trying to show updates and refresh metadata and
whatnot.  Racing and confusion ensues.

We should do something to fix this.
Comment 1 Jesse Keating 2008-04-02 16:20:46 EDT
Maybe make either yum-updatesd or pup or packagekit smart about detecting the
other and not launching?
Comment 2 Jeremy Katz 2008-04-02 23:16:52 EDT
No, the "fix" is probably going to be obsoletes and package blocking.
Comment 3 Matthias Clasen 2008-04-12 17:18:16 EDT
gnome-packagekit-0.1.11-5.fc9
-----------------------------
* Fri Apr 11 2008 Jesse Keating <jkeating@redhat.com> - 0.1.11-5
- Obsolete / Provide pirut.

Note You need to log in before you can comment on or make changes to this bug.