Bug 440346 - duplicity 0.4.9 package doesn't work with python 2.3
duplicity 0.4.9 package doesn't work with python 2.3
Status: CLOSED NEXTRELEASE
Product: Fedora EPEL
Classification: Fedora
Component: duplicity (Show other bugs)
el4
All Linux
medium Severity high
: ---
: ---
Assigned To: Robert Scheck
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-02 19:26 EDT by Max Kanat-Alexander
Modified: 2008-05-05 16:18 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-05 16:18:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Max Kanat-Alexander 2008-04-02 19:26:13 EDT
I installed the 0.4.9 package on my CentOS 4 server, and then every day I
started to get these messages from my daily backup:

Traceback (most recent call last):
  File "/usr/bin/duplicity", line 460, in ?
    with_tempdir(main)
  File "/usr/bin/duplicity", line 455, in with_tempdir
    fn()
  File "/usr/bin/duplicity", line 388, in main
    action = commandline.ProcessCommandLine(sys.argv[1:])
  File "/usr/lib/python2.3/site-packages/duplicity/commandline.py", line 462, in
ProcessCommandLine
    backup, local_pathname = set_backend(args[0], args[1])
  File "/usr/lib/python2.3/site-packages/duplicity/commandline.py", line 372, in
set_backend
    backend1, backend2 = backends.get_backend(arg1), backends.get_backend(arg2)
  File "/usr/lib/python2.3/site-packages/duplicity/backends.py", line 75, in
get_backend
    pu = ParsedUrl(url_string)
  File "/usr/lib/python2.3/site-packages/duplicity/backends.py", line 61, in
ParsedUrl
    if pu.scheme in urlparser.uses_netloc and not pu.hostname:
  File "/usr/lib/python2.3/site-packages/duplicity/urlparse_2_5.py", line 103,
in hostname
    netloc = netloc.rsplit("@", 1)[1]
AttributeError: 'str' object has no attribute 'rsplit'

I see in the spec file that there's a python23 patch, but I guess it's not
covering everything necessary?
Comment 1 Robert Scheck 2008-04-22 16:15:55 EDT
Known problem; looks like we've less epel-testing users around. I also had a talk
with upstream because of this in March. Let me see, whether there's something new
until now.
Comment 2 Robert Scheck 2008-04-23 16:20:39 EDT
Response from upstream today: "I am working on it.  I should be able to have it
in the next release, a couple of weeks away."
Comment 3 Robert Scheck 2008-05-05 16:18:40 EDT
Max, the new version of duplicity (0.4.11) should solve all python 2.3 issues as 
per upstream. Until the package reaches EPEL testing repository, you can grab the
RPM package from the build system repository:

http://buildsys.fedoraproject.org/plague-results/fedora-4-epel/duplicity/0.4.11-1.el4/

I'm going to close this bug report now, as I expect everything to work again. If
something doesn't work, please reopen this bug report immediately and give me all
details. Same applies to you, Shea and a big thanks to Kenneth :)

Note You need to log in before you can comment on or make changes to this bug.