This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 440354 - bdist_rpm fails because an extra file <module>.pyo is created which is not in the INSTALLED_FILES list
bdist_rpm fails because an extra file <module>.pyo is created which is not in...
Status: CLOSED DUPLICATE of bug 236535
Product: Fedora
Classification: Fedora
Component: redhat-rpm-config (Show other bugs)
8
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Jon Masters
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-02 20:32 EDT by Lloyd Kvam
Modified: 2008-04-03 04:41 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-03 04:41:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lloyd Kvam 2008-04-02 20:32:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.13) Gecko/20080325 Fedora/2.0.0.13-1.fc8 Firefox/2.0.0.13

Description of problem:
When the redhat-rpm-config package is removed, the python setup.py bdist_rpm works properly.  I discovered this creating an RPM for demjson, which is a pure Python package and should not have a .pyo file.

Version-Release number of selected component (if applicable):
redhat-rpm-config-9.0.1-1.fc8

How reproducible:
Always


Steps to Reproduce:
1.Obtain pure Python package such as http://deron.meranda.us/python/demjson/dist/demjson-1.3.tar.gz
2.tar xzvf demjson-1.3.tar.gz
3.cd demjson-1.3
python setup.py bdist_rpm

Actual Results:
+ /usr/lib/rpm/find-debuginfo.sh /home/lkvam/download/demjson-1.3/build/bdist.linux-i686/rpm/BUILD/demjson-1.3
find: debug: No such file or directory
+ /usr/lib/rpm/check-buildroot
+ /usr/lib/rpm/redhat/brp-compress
+ /usr/lib/rpm/redhat/brp-strip-static-archive /usr/bin/strip
+ /usr/lib/rpm/redhat/brp-strip-comment-note /usr/bin/strip /usr/bin/objdump
+ /usr/lib/rpm/brp-python-bytecompile
+ /usr/lib/rpm/redhat/brp-python-hardlink
+ /usr/lib/rpm/redhat/brp-java-repack-jars
Processing files: demjson-1.3-1
Requires(rpmlib): rpmlib(CompressedFileNames) <= 3.0.4-1 rpmlib(PayloadFilesHavePrefix) <= 4.0-1
Requires: python(abi) = 2.5
Checking for unpackaged file(s): /usr/lib/rpm/check-files /var/tmp/demjson-1.3-1-buildroot
error: Installed (but unpackaged) file(s) found:
   /usr/lib/python2.5/site-packages/demjson.pyo


RPM build errors:
    Installed (but unpackaged) file(s) found:
   /usr/lib/python2.5/site-packages/demjson.pyo
error: command 'rpmbuild' failed with exit status 1


Expected Results:
+ /usr/lib/rpm/brp-compress
+ /usr/lib/rpm/brp-strip
+ /usr/lib/rpm/brp-strip-static-archive
+ /usr/lib/rpm/brp-strip-comment-note
Processing files: demjson-1.3-1
Requires(rpmlib): rpmlib(CompressedFileNames) <= 3.0.4-1 rpmlib(PayloadFilesHavePrefix) <= 4.0-1
Requires: python(abi) = 2.5
Checking for unpackaged file(s): /usr/lib/rpm/check-files /var/tmp/demjson-1.3-1-buildroot
Wrote: /home/lkvam/demjson-1.3/build/bdist.linux-i686/rpm/SRPMS/demjson-1.3-1.src.rpm
Wrote: /home/lkvam/demjson-1.3/build/bdist.linux-i686/rpm/RPMS/noarch/demjson-1.3-1.noarch.rpm
Executing(%clean): /bin/sh -e /var/tmp/rpm-tmp.17108
+ umask 022
+ cd /home/lkvam/demjson-1.3/build/bdist.linux-i686/rpm/BUILD
+ cd demjson-1.3
+ rm -rf /var/tmp/demjson-1.3-1-buildroot
+ exit 0
Executing(--clean): /bin/sh -e /var/tmp/rpm-tmp.17108
+ umask 022
+ cd /home/lkvam/demjson-1.3/build/bdist.linux-i686/rpm/BUILD
+ rm -rf demjson-1.3
+ exit 0
moving build/bdist.linux-i686/rpm/SRPMS/demjson-1.3-1.src.rpm -> dist
moving build/bdist.linux-i686/rpm/RPMS/noarch/demjson-1.3-1.noarch.rpm -> dist


Additional info:
The expected results were obtained after removing redhat-rpm-config.
Comment 1 Panu Matilainen 2008-04-03 04:41:28 EDT

*** This bug has been marked as a duplicate of 236535 ***

Note You need to log in before you can comment on or make changes to this bug.