Bug 44036 - i810 KDE Xf86 cannot allocate memory
i810 KDE Xf86 cannot allocate memory
Status: CLOSED DUPLICATE of bug 32338
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-09 21:05 EDT by Mike Vanecek
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-12 03:12:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Configuration File at time of error (1.79 KB, text/plain)
2001-06-09 21:06 EDT, Mike Vanecek
no flags Details
XF86 log after error (16.86 KB, text/plain)
2001-06-09 21:08 EDT, Mike Vanecek
no flags Details
Output from startx > xoutput 2>&1 (8.42 KB, text/plain)
2001-06-09 21:10 EDT, Mike Vanecek
no flags Details

  None (edit)
Description Mike Vanecek 2001-06-09 21:05:41 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.2-2 i686)

Description of problem:
Loading KDE with startx on an i810 gets an error i810 KDE Xf86 cannot
allocate memory 

How reproducible:
Always

Steps to Reproduce:
1. startx (only KDE is installed, do not know what happens with Gnome)
2. Look in XFree86 log.
3.
	

Additional info:

(WW) I810(0): xf86AllocateGARTMemory: allocation of 1024 pages failed
	(Cannot allocate memory)
(II) I810(0): No physical memory available for 4194304 bytes of DCACHE
Comment 1 Mike Vanecek 2001-06-09 21:06:29 EDT
Created attachment 20699 [details]
Configuration File at time of error
Comment 2 Mike Vanecek 2001-06-09 21:08:53 EDT
Created attachment 20700 [details]
XF86 log after error
Comment 3 Mike Vanecek 2001-06-09 21:10:03 EDT
Created attachment 20701 [details]
Output from startx > xoutput 2>&1
Comment 4 Mike A. Harris 2001-06-12 00:48:34 EDT
Disable the RENDER extension in your config file.  Render isn't supported
on i810.  This means no AA fonts in KDE also, so make sure AA fonts are
disabled.  The missing symbol errors have been fixed already in
XFree86-4.0.3-21 which will be released shortly on my test site.

Does the problem go away if you run "modprobe agpgart" as root prior
to starting X?
Comment 5 Mike A. Harris 2001-06-12 03:12:12 EDT
It appears that this might also be a CMOS misconfiguration problem.
Others have reported i810/815 bugs have went away after correcting
bad settings for memory in their CMOS configuration.
Comment 6 Mike A. Harris 2001-06-12 03:14:17 EDT
This bug is a dupe.  Please update the dupe report with any info.  I'll add
you to the Cc.

*** This bug has been marked as a duplicate of 32338 ***

Note You need to log in before you can comment on or make changes to this bug.