Bug 440368 - FTBFS xen-3.2.0-10.fc9
FTBFS xen-3.2.0-10.fc9
Status: CLOSED DUPLICATE of bug 429723
Product: Fedora
Classification: Fedora
Component: mock (Show other bugs)
rawhide
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Xen Maintainance List
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
: Reopened
Depends On:
Blocks: FTBFS
  Show dependency treegraph
 
Reported: 2008-04-03 00:34 EDT by FTBFS
Modified: 2008-04-03 12:11 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-03 12:11:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
root.log.bz (1.97 KB, application/x-bzip2)
2008-04-03 00:35 EDT, FTBFS
no flags Details
build.log.bz (475 bytes, application/x-bzip2)
2008-04-03 00:35 EDT, FTBFS
no flags Details

  None (edit)
Description FTBFS 2008-04-03 00:34:57 EDT
xen-3.2.0-10.fc9.src.rpm Failed To Build From Source
Comment 1 FTBFS 2008-04-03 00:35:04 EDT
Created attachment 300174 [details]
root.log.bz

root.log for x86_64
Comment 2 FTBFS 2008-04-03 00:35:06 EDT
Created attachment 300175 [details]
build.log.bz

build.log for x86_64
Comment 3 Daniel Berrange 2008-04-03 07:52:49 EDT
Your mock config is broken & excluding i386 packages on x86_64 which is required
to build the BIOS.
Comment 4 FTBFS 2008-04-03 11:50:43 EDT
It's using the configs that mock provides...
Comment 5 FTBFS 2008-04-03 12:05:09 EDT
reopen and reassign to mock.  The exclude line being used should have allowed
glibc.i?86 to be included, but clearly it wasn't.

# grub/syslinux on x86_64 need glibc-devel.i386 which pulls in glibc.i386, need
to exclude all
# .i?86 packages except these.
exclude=[0-9A-Za-fh-z]*.i?86 g[0-9A-Za-km-z]*.i?86 gl[0-9A-Za-hj-z]*.i?86
gli[0-9A-Zac-z]*.i?86 glib[0-9A-Za-bd-z]*.i?86


yet root.log shows:
No Package Found for /usr/include/gnu/stubs-32.h
which is provided by glibc-devel.i686  So it's ugly, but we need to not exclude
glibc-devel.i?86.

Reassigning to mock.
Comment 6 Daniel Berrange 2008-04-03 12:11:34 EDT
I reported this mock bug months ago but it seems it was never fixed :-(

https://bugzilla.redhat.com/show_bug.cgi?id=429723

*** This bug has been marked as a duplicate of 429723 ***

Note You need to log in before you can comment on or make changes to this bug.