Bug 440377 - [i18n][CKJI][Indic] evolution mail printing failed
Summary: [i18n][CKJI][Indic] evolution mail printing failed
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gtkhtml3
Version: 9
Hardware: i386
OS: Linux
low
low
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 415471 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-04-03 07:29 UTC by Yu Shao
Modified: 2008-10-22 19:37 UTC (History)
5 users (show)

Fixed In Version: evolution-2.24.1-1.fc10
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-10-22 19:37:47 UTC


Attachments (Terms of Use)
Screenshot attached illustrating the problem, print as draft (91.84 KB, application/postscript)
2008-04-03 07:29 UTC, Qing LIN
no flags Details
Screenshot attached illustrating the problem, print directly (28.84 KB, application/postscript)
2008-04-03 07:31 UTC, Qing LIN
no flags Details


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 527201 None None None Never

Description Qing LIN 2008-04-03 07:29:44 UTC
Description of problem:
Printing result is messed up or nothing printed

Version-Release number of selected component (if applicable):
evolution-2.22.0-1.fc9.i386

How reproducible:
Always

Steps to Reproduce:
1. Start evolution in zh_CN locale and select New mail
2. In the "Message Body", copy and paste the contents from the following URL:
http://i18n.brisbane.redhat.com/~llim/rendering/CJKI%20bold-nornal%20font%20compare
3. Save and goto draft folder, select the draft and printer it to ps file.
4. Check the result
  
Actual results:
The characters' fonts are messed up

Expected results:
Should print the original content

Additional info:
If print directly, instead of saving as draft first, the content will be nothing.

Comment 1 Qing LIN 2008-04-03 07:29:44 UTC
Created attachment 300186 [details]
Screenshot attached illustrating the problem, print as draft

Comment 2 Qing LIN 2008-04-03 07:31:51 UTC
Created attachment 300187 [details]
Screenshot attached illustrating the problem, print directly

Comment 3 Qing LIN 2008-04-03 07:34:01 UTC
Same problem occurs in f9 beta-zh_CN, alpha-ko_KR/zh_TW/ja_JP/zh_CN

Comment 4 Matthew Barnes 2008-04-09 18:36:33 UTC
*** Bug 415471 has been marked as a duplicate of this bug. ***

Comment 5 Matthew Barnes 2008-04-09 18:37:46 UTC
This also affects Indic locales.  Adjusting summary.  Looks like a GtkHTML bug.

Comment 6 Matthew Barnes 2008-04-09 18:45:07 UTC
Opened an upstream bug for this, but I'll leave this open for now so the i18n
team can track it.

http://bugzilla.gnome.org/show_bug.cgi?id=527201

Comment 8 Tony Fu 2008-09-10 03:15:20 UTC
requested by Jens Petersen (#27995)

Comment 9 Matthew Barnes 2008-10-22 19:37:47 UTC
I retested this with Evolution 2.24.1 and printing both from the composer window and from the Drafts folder is working fine.  The link in the reproducer steps above is no longer good, but the upstream bug has a copy of the HTML page.

Closing this as CURRENTRELEASE.


Note You need to log in before you can comment on or make changes to this bug.