Bug 440436 - access into large isos (>4GB) is broken
access into large isos (>4GB) is broken
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: fuseiso (Show other bugs)
8
All Linux
low Severity high
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-03 11:29 EDT by Thomas Bittermann
Modified: 2008-04-16 23:53 EDT (History)
0 users

See Also:
Fixed In Version: 20070708-4.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-16 23:53:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
patch which fixes support for isos > 4GB (2.34 KB, patch)
2008-04-03 11:29 EDT, Thomas Bittermann
no flags Details | Diff

  None (edit)
Description Thomas Bittermann 2008-04-03 11:29:23 EDT
Description of problem:
Accessing content in isos larger than 4gb (mounted with fuseiso) does not work -
you can only access files in the are < 4gb.

Version-Release number of selected component (if applicable):
20070708-3

How reproducible:

Steps to Reproduce:
1. fuseiso CentOS-5.1-x86_64-bin-DVD.iso /mnt/cdrom
2. rpm -qpi /mnt/cdrom/ypbind-1.19-8.el5.x86_64.rpm

Actual results:
fails with "... no rpm ..."

Expected results:
display rpm package information

Additional info:
Checked the isos md5 and sha1 sum - were ok, checked the access into the iso
while mounted as loop device - worked fine.

The problem is in isofs.h:
typedef struct _isofs_context {
...
size_t block_size; // raw block size
size_t block_offset; // offset from block start ...
size_t data_size; // data size inside block
...
}

size_t is simply "too small".

The appended patch worked for me on RHEL4u6 and Fedora 8.

Greetings
Thomas
Comment 1 Thomas Bittermann 2008-04-03 11:29:23 EDT
Created attachment 300266 [details]
patch which fixes support for isos > 4GB
Comment 2 Thomas Bittermann 2008-04-03 11:30:37 EDT
I also sent the patch to upstream ...
Comment 3 Tom "spot" Callaway 2008-04-03 11:36:59 EDT
This is obviously correct. I'll apply the patch and push updates.

Thanks for the patch.
Comment 4 Fedora Update System 2008-04-03 14:12:09 EDT
fuseiso-20070708-4.fc7 has been submitted as an update for Fedora 7
Comment 5 Fedora Update System 2008-04-03 14:12:54 EDT
fuseiso-20070708-4.fc8 has been submitted as an update for Fedora 8
Comment 6 Fedora Update System 2008-04-09 01:15:20 EDT
fuseiso-20070708-4.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update fuseiso'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F7/FEDORA-2008-2930
Comment 7 Fedora Update System 2008-04-16 23:53:39 EDT
fuseiso-20070708-4.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2008-04-16 23:53:57 EDT
fuseiso-20070708-4.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.