Bug 440443 - root everything IPA does under /ipa
root everything IPA does under /ipa
Status: CLOSED ERRATA
Product: freeIPA
Classification: Community
Component: build (Show other bugs)
1.0
All Linux
high Severity low
: ---
: ---
Assigned To: Rob Crittenden
Chandrasekar Kannan
:
Depends On:
Blocks: freeipa10 429034
  Show dependency treegraph
 
Reported: 2008-04-03 11:47 EDT by Rob Crittenden
Modified: 2015-01-04 18:31 EST (History)
2 users (show)

See Also:
Fixed In Version: freeipa-2.0.0-1.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-27 03:13:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Put everything IPA into /ipa (12.96 KB, patch)
2008-04-03 15:23 EDT, Rob Crittenden
no flags Details | Diff
version the changed configuration files as well (18.97 KB, patch)
2008-05-06 16:11 EDT, Rob Crittenden
no flags Details | Diff
put ipa-updateconfig in ipa-server (18.91 KB, patch)
2008-05-07 09:34 EDT, Rob Crittenden
no flags Details | Diff

  None (edit)
Description Rob Crittenden 2008-04-03 11:47:19 EDT
The current UI and xmlrpc scripts aren't completely separated in the web space.

As discussed in IRC with some folks from libvert we should probably put
everything we use into /ipa and go from there, so:

/ipa/ui - TurboGears UI
/ipa/static - static files
/ipa/config - configuration
/ipa/errors - error pages
/ipa/xml - xmlrpc interface
Comment 1 Rob Crittenden 2008-04-03 11:47:52 EDT
We should do this prior to 1.0 because updating the configuration on the fly
would be harder than getting this in first.
Comment 2 Rob Crittenden 2008-04-03 15:23:16 EDT
Created attachment 300310 [details]
Put everything IPA into /ipa
Comment 4 Rob Crittenden 2008-05-06 16:11:40 EDT
Created attachment 304680 [details]
version the changed configuration files as well

The core of the patch is the same, this adds ipa-updateconfig to change the
configuration for updated servers.
Comment 5 Rob Crittenden 2008-05-07 09:34:37 EDT
Created attachment 304769 [details]
put ipa-updateconfig in ipa-server
Comment 6 Rob Crittenden 2008-05-07 09:42:01 EDT
ipa-1-0: 8b77a12bf00c6934cd6aefe4e8557feb0ea8d5bd
master: 8e7561cff6df60e470f1a576f8dca3f025db0586
Comment 7 Yi Zhang 2008-05-23 14:47:07 EDT
where is this ipa-updateconfig file located?
Comment 8 Rob Crittenden 2008-05-23 14:55:50 EDT
/usr/sbin

This is not something expected to be run by an end-user though.
Comment 9 Yi Zhang 2008-05-27 13:11:22 EDT
QA Verified on May 27, 2008 (Yi)

This is a bit hard to verify. 

I manually check all links on every ipa web gui pages, and i find all links are
under /ipa 

I will close this bug for now. If there are some objection to my test method or
any page that being found not under /ipa, I will re-open this bug. 


Note You need to log in before you can comment on or make changes to this bug.