Bug 440445 - udev times out on boot, network and sound missing
udev times out on boot, network and sound missing
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i386 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-04-03 12:02 EDT by Jón Fairbairn
Modified: 2008-06-27 02:56 EDT (History)
0 users

See Also:
Fixed In Version: 2.6.25-14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-06-27 02:56:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
dmesg output, booted with debug on the command line (21.96 KB, text/plain)
2008-04-03 12:02 EDT, Jón Fairbairn
no flags Details
/var/log/messages extract command line udevdebug (79.76 KB, text/plain)
2008-04-04 12:35 EDT, Jón Fairbairn
no flags Details

  None (edit)
Description Jón Fairbairn 2008-04-03 12:02:20 EDT
Description of problem:

Booting with kernel > kernel- I get a long
wait when udev starts and then a timeout, then no network or sound.

Version-Release number of selected component (if applicable):

kernel- (this is the latest I've tried; all
kernel updates I've tried since (but not including) have had (what appears to be) the same

How reproducible:


Steps to Reproduce:
1. boot with kernel
2. wait while udev times out
3. login and observe state of machine
Actual results:
Network manager reports that there is no interface eth0
the volume control applet indicates that there is no sound

Expected results:
no timeout from udev, eth0 and sound should work 

Additional info:
Machine is an IBM thinkpad X30 26724XG
eth0 is driven by e100
Comment 1 Jón Fairbairn 2008-04-03 12:02:20 EDT
Created attachment 300275 [details]
dmesg output, booted with debug on the command line
Comment 2 Chuck Ebbert 2008-04-03 21:54:02 EDT
Can you try adding "udevdebug" to the boot options?
Comment 3 Jón Fairbairn 2008-04-04 12:35:06 EDT
Created attachment 300894 [details]
/var/log/messages extract command line udevdebug

I can, and I get *lots* of logging on the console, but with
debug and udevdebug on the command line, unless I boot
single, the system never (for as long as I've waited) gives
me a shell. Booting single, I get a shell, but dmesg
contains none of the udevdebug messages (even if I set
udev_log="debug" in /etc/udev/udev.conf.

The attachment is with udevdebug (but not debug) on the
kernel command line; this is the best I could get.

Scroll lock during udev start-up shows that nearly half of
the messages are "udev_rules_iter_label: moving forward
looking for label 'libsane_rules_end'" (if I wrote that down
correctly). /etc/udev/rules.d/60-libsane.rules is as
packaged in sane-backends-1.0.18-17.fc8

Ironically, if booted with debug udevdebug, although I don't
get a login shell I do get eth0 started -- it responds to
pings, but there's no useful service running.
Comment 4 Jón Fairbairn 2008-06-27 02:56:05 EDT
This bug seems to have disappeared by Fedora 9

Note You need to log in before you can comment on or make changes to this bug.