Bug 440454 - gnbd_import fails on ppc, cannot get timestamp
gnbd_import fails on ppc, cannot get timestamp
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gnbd (Show other bugs)
5.2
ppc64 Linux
low Severity low
: rc
: ---
Assigned To: Ben Marzinski
:
Depends On:
Blocks: Cluster5-ppc
  Show dependency treegraph
 
Reported: 2008-04-03 12:47 EDT by Nate Straz
Modified: 2009-04-16 18:51 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 15:57:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nate Straz 2008-04-03 12:47:27 EDT
Description of problem:

When trying to import GNBD devices on a ppc system from another ppc system, I
get the following error:

[root@kent ~]# gnbd_import -i basic
gnbd_import: created gnbd device sdc
gnbd_recvd: ERROR cannot get timestamp : Invalid argument
gnbd_import: ERROR gnbd_recvd failed


Version-Release number of selected component (if applicable):
gnbd-1.1.5-1.el5
kmod-gnbd-0.1.4-12.el5

How reproducible:
100%

Steps to Reproduce:
1. on nodeA: gnbd_export -c -d /dev/sdc1 -e sdc
2. on nodeB: gnbd_import -i nodeA
  
Actual results:
See above

Expected results:
The import should work.

Additional info:
Comment 1 Ben Marzinski 2008-04-16 17:08:53 EDT
The problem is that all of our userspace programs on the ppc64 are 32bit
binaries, and the gnbd kernel module does not handle ioctl32 calls.  The
solution is either to build the userspace programs (at least gnbd_recvd) as
64bit binaries, or to make the gnbd kernel module handle ioctl32 calls.
Comment 3 RHEL Product and Program Management 2008-07-31 17:40:54 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 4 Ben Marzinski 2008-08-25 11:09:16 EDT
Oops. This was checked in a while ago.
Comment 7 errata-xmlrpc 2009-01-20 15:57:24 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0102.html

Note You need to log in before you can comment on or make changes to this bug.