Bug 440455 - Evolution can't read mailbox file bigger then 2 GB
Evolution can't read mailbox file bigger then 2 GB
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
8
i686 Linux
low Severity low
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-03 12:48 EDT by Borut Semenic
Modified: 2008-05-19 14:12 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-19 14:12:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 522433 None None None Never

  None (edit)
Description Borut Semenic 2008-04-03 12:48:06 EDT
Description of problem:
Evolution can't read mailbox file bigger then 2 GB 

Version-Release number of selected component (if applicable):
evolution-2.12.3-3.fc8

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:
 

Expected results:


Additional info:
system is fully updated
Comment 1 Milan Crha 2008-04-03 13:23:15 EDT
Can you paste here exact error message it showed to you, please?
Either from the UI or on Evolution's console. (I'm not sure whether the error
I'm thinking of is shown in UI or on console only.)

Thanks in advance.
Comment 2 Borut Semenic 2008-04-03 14:03:02 EDT
There is no error. I can't access this file with evolution. It is subfolder file
which disappear from evolution. There was sam message but I don't remember it.

I thinh that evolution can't read mailbox files bigger then 2 GB 

Comment 3 Milan Crha 2008-04-03 14:24:44 EDT
I checked in code and 2.12.3 uses a large file support. Not on all places, but
that was the question for that error messages, whether it failed there where I
think it did or somewhere else. I'm also not sure how well it works on 32 bit
machines (it's out of range for them a bit), but I will try to generate such
mailbox tomorrow and update bug.
Comment 4 Borut Semenic 2008-04-04 05:51:26 EDT
There is the same problem on Ubuntu if that can help in someway

https://bugs.launchpad.net/evolution/+bug/197290 
Comment 5 Milan Crha 2008-04-04 10:47:52 EDT
I tried create a large mbox file on my 64 bit machine and it works as expected.
I will try to also on 32 bit machine as soon as I setup some.

Thanks for the bug link, I thought it claims there, (the message they provided),
I will try to propose a patch to upstream, will see what they will think about that.
Comment 6 Milan Crha 2008-04-04 12:09:07 EDT
There's an upstream bug for that,
http://bugzilla.gnome.org/show_bug.cgi?id=522433
initiated by ubuntu guy.
I will close this as upstream and backport patch as soon as it will be accepted.
Comment 7 Fedora Update System 2008-04-04 13:52:52 EDT
evolution-data-server-1.12.3-5.fc8 has been submitted as an update for Fedora 8
Comment 8 Milan Crha 2008-04-04 13:57:49 EDT
The above package is in updates-testing. It would be great if you can try
whether the fix there fixes your problem.

Just to be sure, can you check whether you've still the file in
~/.evolution/mail/<account_type>/... where <account_type> stands for "local",
"imap", and so on. I just wonder whether the file was kept there or evo broke it
and thus doesn't show the content.
Comment 9 Borut Semenic 2008-04-05 01:41:43 EDT
I update the evolution-data-server-1.12.3-5.fc8. When I try to add the subfolder
to inbox and and the same name for subfolder. there is a message: 

Cannot create folder: /home/boruts/.evolution/mail/local/Inbox.sbd/Helena: Value
too large for defined data type

I can't import it because "file type" and "forward" button are not accessible
(they are grey ). 

So it is not good to go

Best regards
 

Comment 10 Milan Crha 2008-04-07 05:12:24 EDT
I found a page about the error message, even not sure whether it's in lseek,
then such change defined there should help, I guess:
http://help.lockergnome.com/linux/lseek-large-defined-data-type-ftopict481415.html

Long story short, I'm not sure whether your i686 system will be able to handle
64 bit offsets anyway, but we can try, sure. Let me check with upstream what
they think.
Comment 11 Borut Semenic 2008-04-07 05:42:52 EDT
Thanks for your help

I think there should be same kind of mechanism which would warn user that capacity
of mailbox is near the limit ...

Best regards
Comment 12 Milan Crha 2008-04-07 15:44:41 EDT
Thanks for the testing. I reported to upstream too and even the upstream bug
contains another fix for this (in configure.in file), then at this point it's
too late for us to risk breaking evolution-data-server's ABI in Fedora 8 or 9,
but this will be supported in Fedora 10.

The problem with that change is that it changes size of one type, and this type
is used in public API, so as Matt mentioned, all the other packages which
use/extend this API will break because it will expect smaller argument, then it
is. (The change was from 32bit to 64bit, thus the newer version has parameters
twice big.)

You can read the public discussion here:
http://mail.gnome.org/archives/evolution-hackers/2008-April/msg00006.html
Comment 13 Matthew Barnes 2008-05-19 14:12:48 EDT
Moving this upstream.  Please see [1] for further updates.

[1] http://bugzilla.gnome.org/show_bug.cgi?id=522433

Note You need to log in before you can comment on or make changes to this bug.