Bug 440475
| Summary: | ipa_webgui does not start after initial installation | ||||||
|---|---|---|---|---|---|---|---|
| Product: | [Retired] freeIPA | Reporter: | Rob Crittenden <rcritten> | ||||
| Component: | WebUI | Assignee: | Rob Crittenden <rcritten> | ||||
| Status: | CLOSED ERRATA | QA Contact: | Chandrasekar Kannan <ckannan> | ||||
| Severity: | high | Docs Contact: | |||||
| Priority: | high | ||||||
| Version: | 1.0 | CC: | benl, jgalipea, ssorce | ||||
| Target Milestone: | --- | ||||||
| Target Release: | --- | ||||||
| Hardware: | All | ||||||
| OS: | Linux | ||||||
| Whiteboard: | |||||||
| Fixed In Version: | freeipa-2.0.0-1.fc15 | Doc Type: | Bug Fix | ||||
| Doc Text: | Story Points: | --- | |||||
| Clone Of: | Environment: | ||||||
| Last Closed: | Type: | --- | |||||
| Regression: | --- | Mount Type: | --- | ||||
| Documentation: | --- | CRM: | |||||
| Verified Versions: | Category: | --- | |||||
| oVirt Team: | --- | RHEL 7.3 requirements from Atomic Host: | |||||
| Cloudforms Team: | --- | Target Upstream Version: | |||||
| Embargoed: | |||||||
| Bug Depends On: | |||||||
| Bug Blocks: | 246164, 453489 | ||||||
| Attachments: |
|
||||||
Created attachment 300316 [details]
move ipa.conf creation earlier in installation
committed as changeset 769 fix verified: ipa_webgui running directly after installation. [root@jennyv4 log]# ps -ef | grep ipa root 12238 1 0 01:18 ? 00:00:00 ipa_kpasswd apache 12365 1 0 01:19 ? 00:00:01 /usr/bin/python -E /usr/sbin/ipa_webgui |
After installation ipa_webgui does not start. It errors out with this in /var/log/ipaerror.log: ERROR:root:failed to start web gui: IPA server not found in DNS, in the config file (/etc/ipa/ipa.conf) or on the command line. File "/usr/sbin/ipa_webgui", line 178, in <module> main() File "/usr/sbin/ipa_webgui", line 173, in main from ipagui.controllers import Root File "/usr/share/ipa/ipagui/controllers.py", line 34, in <module> from subcontrollers.user import UserController File "/usr/share/ipa/ipagui/subcontrollers/user.py", line 32, in <module> from ipacontroller import IPAController File "/usr/share/ipa/ipagui/subcontrollers/ipacontroller.py", line 35, in <module> ipa.config.init_config() File "/usr/lib/python2.5/site-packages/ipa/config.py", line 151, in init_config raise IPAConfigError("IPA server not found in DNS, in the config file (/etc/ipa/ipa.conf) or on the command line.") I wonder if this is a timing issue, that we aren't writing /etc/ipa/ipa.conf until after we start the UI.