Bug 440485 - nash fails to mount LVM Volumegroup and crashes
nash fails to mount LVM Volumegroup and crashes
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
9
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-03 14:42 EDT by Harald Hoyer
Modified: 2009-02-03 06:00 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-03 06:00:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
nash crash (143.38 KB, image/png)
2008-04-03 14:42 EDT, Harald Hoyer
no flags Details
old init from initrd (2.77 KB, text/plain)
2008-04-03 14:54 EDT, Harald Hoyer
no flags Details
new init from mkinitrd (2.43 KB, text/plain)
2008-04-03 14:54 EDT, Harald Hoyer
no flags Details
failure to read stripe table (64.78 KB, image/png)
2008-04-03 15:03 EDT, Harald Hoyer
no flags Details
mkinitrd detailed (426.25 KB, text/plain)
2008-04-03 16:19 EDT, Harald Hoyer
no flags Details
patch for mkinitrd (1.52 KB, patch)
2008-04-03 17:36 EDT, Harald Hoyer
no flags Details | Diff

  None (edit)
Description Harald Hoyer 2008-04-03 14:42:42 EDT
$ rpm -q mkinitrd kernel
mkinitrd-6.0.41-1.fc9.x86_64
kernel-2.6.25-0.185.rc7.git6.fc9.x86_64

kernel-2.6.24.3-50.fc8.x86_64 works with the old generated mkinitrd.

Screenshot of crash attached.

How can I help to debug?
Comment 1 Harald Hoyer 2008-04-03 14:42:42 EDT
Created attachment 300301 [details]
nash crash
Comment 2 Harald Hoyer 2008-04-03 14:54:20 EDT
Created attachment 300303 [details]
old init from initrd
Comment 3 Harald Hoyer 2008-04-03 14:54:45 EDT
Created attachment 300304 [details]
new init from mkinitrd
Comment 4 Harald Hoyer 2008-04-03 15:03:36 EDT
Created attachment 300306 [details]
failure to read stripe table
Comment 5 Harald Hoyer 2008-04-03 15:53:47 EDT
for the reference. It's all due to missing modules:

# diff -u t1t t3t
--- t1t	2008-04-03 21:23:51.000000000 +0200
+++ t3t	2008-04-03 21:43:10.000000000 +0200
@@ -6,11 +6,7 @@
 echo "Loading dm-zero module"
 echo "Loading ehci-hcd module"
 echo "Loading ext3 module"
-echo "Loading jbd module"
 echo "Loading libata module"
-echo "Loading mbcache module"
 echo "Loading ohci-hcd module"
-echo "Loading scsi_mod module"
-echo "Loading sd_mod module"
 echo "Loading uhci-hcd module"
 echo "Loading usb-storage module"
Comment 6 Harald Hoyer 2008-04-03 16:19:05 EDT
Created attachment 300331 [details]
mkinitrd detailed

sh -x mkinitrd -v  -f /boot/initrd-2.6.25-0.185.rc7.git6.fc9.x86_64.img
2.6.25-0.185.rc7.git6.fc9.x86_64 > /root/mk.txt 2>&1
Comment 7 Harald Hoyer 2008-04-03 17:36:30 EDT
Created attachment 300349 [details]
patch for mkinitrd
Comment 8 Peter Jones 2008-04-07 12:11:49 EDT
Should be fixed in 6.0.43 .  Please test.
Comment 9 Bug Zapper 2008-05-14 04:37:50 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.