Bug 440499 - SElinux complians about improperly labeled files in /root and home dirs, but resotrecon doesn't change labels
SElinux complians about improperly labeled files in /root and home dirs, but ...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: setroubleshoot (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
NeedsRetesting
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-03 16:16 EDT by Jesse Keating
Modified: 2013-01-09 22:19 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-14 11:09:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jesse Keating 2008-04-03 16:16:18 EDT
setroubleshoot pops up an alert when trying ot run system-config-keyboard,
stating that it is preventing loadkeys from using potentially mislabled files
(in this case, /home/jkeating/.xsession-errors).  It suggests running restorecon
on the file, yet this has no effect upon the file.

system_u:object_r:user_home_t:s0 /home/jkeating/.xsession-errors
Comment 1 Daniel Walsh 2008-04-04 17:34:47 EDT
Yes this seems to be a bad catch by setroubleshoot.

BTW This avc should not happen with latest policy.

Could you attach the AVC that caused it?
Comment 2 Jesse Keating 2008-04-05 14:28:46 EDT
It was from rawhide a few days ago, so a new policy could have happened since. 
I'll retest, or have QA retest.  It's as simple as trying to ryn
system-config-keyboard and requesting a changed layout.
Comment 3 Jon Stanley 2008-04-14 11:09:00 EDT
No AVC, but new error switching back to US English.  Will file a new bug about
that :(

Note You need to log in before you can comment on or make changes to this bug.