Bug 440543 - CA's web-services page needs improvements
CA's web-services page needs improvements
Status: CLOSED ERRATA
Product: Dogtag Certificate System
Classification: Community
Component: CA (Show other bugs)
1.0
All Linux
low Severity low
: ---
: ---
Assigned To: Matthew Harmsen
Chandrasekar Kannan
:
Depends On:
Blocks: 443788
  Show dependency treegraph
 
Reported: 2008-04-03 17:59 EDT by Bob Lord
Modified: 2015-01-04 18:31 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-22 19:28:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
GUI, Copyright, License, and Typo changes (Dogtag) (52 bytes, text/plain)
2009-03-25 19:36 EDT, Matthew Harmsen
no flags Details

  None (edit)
Description Bob Lord 2008-04-03 17:59:04 EDT
Description of problem:
When you build a new CA on the command line, it will direct you to visit a URL
that contains information about how to access both Agent and end-user web pages.

The URL looks like this:
https://machine1.example.com:9443/ca/services

There are several things that should be changed on this page:
1. The Dogtag logo is too small to see properly.  It should be much larger.
2. The text below the logo says "Certificate System", which is redundant with
the title text to the right, which says "Dogtag Certificate System"
3. The title text is too small.
4. The title text is a link that leads back to the same page, which is pointless.
5. There is a Red Hat copyright at the bottom which isn't accurate.  It should
be removed.

If someone wants to come up with a new mockup, I'd love to see it! :-)


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 2 Matthew Harmsen 2009-03-25 19:35:24 EDT
This bug is being addressed in a more global sense by Bugzilla Bug #488388.
Comment 3 Matthew Harmsen 2009-03-25 19:36:12 EDT
Created attachment 336722 [details]
GUI, Copyright, License, and Typo changes (Dogtag)
Comment 5 Matthew Harmsen 2009-03-25 19:37:51 EDT
Comment on attachment 336722 [details]
GUI, Copyright, License, and Typo changes (Dogtag)

CAVEATS:

(1) There is a display "glitch" in the SecurityDomainLogin() pages of non-CA
    subsystems,
(2) There is a rogue "certificate system" displayed on pages produced by RA
    subsystem CGI scripts
(3) Service Pages should uniquely identify which PKI subystem they represent
Comment 6 Andrew Wnuk 2009-03-25 19:41:28 EDT
attachment (id=336722) +awnuk
Comment 8 Matthew Harmsen 2009-03-25 19:58:51 EDT
These issues (with the exception of number 4) have been addressed in the checkins of Bugzilla Bug #488388.  All future activity should be tracked by this bug.
Comment 10 Jenny Galipeau 2009-06-12 06:28:55 EDT
1) does not apply to RHCS
2) Text Beside the logo says Red Hat Certificate System
3) Text size is adequate
5) was verified with bug 488388

4) The text link still leads back to itself and is not needed.
Comment 11 Matthew Harmsen 2009-07-14 20:26:11 EDT
Changing 4) has been rejected as it causes no harm.
Comment 13 Jenny Galipeau 2009-07-15 09:08:08 EDT
Closing bug verified:

4) new bug opened for bad link bug #511859

Note You need to log in before you can comment on or make changes to this bug.