Bug 440567 - [bn_IN] bn-itrans.mim does not work
[bn_IN] bn-itrans.mim does not work
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: m17n-db (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Parag Nemade
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F9Target
  Show dependency treegraph
 
Reported: 2008-04-03 23:17 EDT by Jens Petersen
Modified: 2008-05-07 21:17 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-07 21:17:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
bn-itrans.mim file used on Fedora 8 for successful typing (4.66 KB, application/octet-stream)
2008-04-04 04:47 EDT, Runa Bhattacharjee
no flags Details

  None (edit)
Description Jens Petersen 2008-04-03 23:17:28 EDT
Description of problem:
Bengali itrans map seems to have an issue since it causes scim to crash and
restart.  I guess either the map should be fixed or if not disabled for now.

How reproducible:
Every time

Steps to Reproduce:
1. Install bengali-support
2. turn on scim IM if necessary with im-chooser
3. restart desktop
4. switch scim to Bengali Itrans map
  
Actual results:
4. scim crashes and restarts

Expected results:
4. no restart and itrans to work

Additional info:
SCIM shouldn't really crash because of a map
but anyway if there is something wrong with with map it should be fixed.
Comment 1 Runa Bhattacharjee 2008-04-04 04:47:30 EDT
Created attachment 300397 [details]
bn-itrans.mim file used on Fedora 8 for successful typing

bn-itrans.mim file used on Fedora 8 for successful typing
Comment 2 Runa Bhattacharjee 2008-04-04 04:48:32 EDT
Can replicate the crash on Fedora 8.

Tried typing with the attached bn-itrans.mim file [1]. No crash.

[1] https://bugzilla.redhat.com/attachment.cgi?id=300397
Comment 3 Jens Petersen 2008-04-04 05:02:08 EDT
The problem should be caused by the final

-  ("L^I" (delete @-) "ৣ"))		; not in ITRANS Bengali table

in bn-itrans-t-182227.patch
Comment 4 Parag Nemade 2008-04-04 06:23:48 EDT
Built for rawhide.
updated patch bn-itrans-t-182227.patch

new rpm can be downloaded from
http://koji.fedoraproject.org/packages/m17n-db/1.5.1/3.fc9/noarch/m17n-db-bengali-1.5.1-3.fc9.noarch.rpm

Note You need to log in before you can comment on or make changes to this bug.