Bug 440594 - rpm -V error: SELinux context differs for syslog.conf
rpm -V error: SELinux context differs for syslog.conf
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: sysklogd (Show other bugs)
4.7
All Linux
low Severity low
: rc
: ---
Assigned To: Peter Vrabec
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-04 05:34 EDT by Chris Ward
Modified: 2010-03-09 09:54 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-09 09:54:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Chris Ward 2008-04-04 05:34:24 EDT
Description of problem:
SELinux context differs when I run rpm -V for the current RHEL4 build of
sysklogd-1.4.1-27.el4 and the previous version sysklogd-1.4.1-26_EL, even if
freshly installed. 

sysklogd-1.4.1-44.el5.i386, the current release for RHEL5 doesn't have the same
problem. 

%> rpm -q sysklogd
sysklogd-1.4.1-27.el4.x86_64

%> rpm -V sysklogd
S.5....T. c /etc/sysconfig/syslog
S.5....TC c /etc/syslog.conf
        ^
# verify error 'C' = SELinux Context Differs


I have a feeling this isn't a major problem, considering the older version had
the same problem...but nonetheless, less verify errors, the better. 

I'm honestly not sure what's causing the verify error to occur, perhaps it's a
bug in rpm -V itself, because when I check the context of syslog.conf, it
appears to be correct.


%> rpm -V sysklogd
S.5....TC c /etc/syslog.conf
        ^

%> ls -Z /etc/syslog.conf 
-rw-r--r--  root     root     user_u:object_r:etc_t            /etc/syslog.conf

%> restorecon /etc/syslog.conf 

%> ls -Z /etc/syslog.conf 
-rw-r--r--  root     root     user_u:object_r:etc_t            /etc/syslog.conf

%> rpm -V sysklogd
S.5....TC c /etc/syslog.conf
        ^

%> rpm -q sysklogd

sysklogd-1.4.1-27.el4.x86_64


Version-Release number of selected component (if applicable):
sysklogd-1.4.1-27.el4

How reproducible:
always

Steps to Reproduce:
1.see above
2.
3.
  
Expected results:
no SELinux context verify error
Comment 1 Daniel Walsh 2008-04-08 09:16:37 EDT
It is checking the SELinux user of the file user_u versus system_u.

If you run restorecon -F /etc/syslog.conf 
it should fix the file so RPM will not complain.

This was fixed to not check the user componant in later versions of rpm.
Comment 2 Peter Vrabec 2008-04-10 05:54:28 EDT
so, is this rpm problem? Should I reassign the issue?
Comment 3 Chris Ward 2008-04-10 07:29:57 EDT
Exactly what I'm thinking, should this bug be reassigned to rpm then? Should rpm
be checking the user of the file user_u versus system_u?
Comment 4 Daniel Walsh 2008-04-10 11:23:05 EDT
I think the problem is the checking at all.  rpm -V checking of SELinux context
was removed from newer versions or rpm.  It is arguable either way, that this is
correct behavior, since it does not match the default context.  

Note You need to log in before you can comment on or make changes to this bug.