Bug 4406 - chage not Y2K compliant - does not recognize 4-digit years
chage not Y2K compliant - does not recognize 4-digit years
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: shadow-utils (Show other bugs)
6.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-08-06 15:11 EDT by jhardin
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-15 13:23:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jhardin 1999-08-06 15:11:59 EDT
The "chage" account maintenance tool does not accept
four-digit-year dates when setting the expiry date.
When entered on the command line, four-digit-year dates are
quietly ignored. When entered interactively, an error is
displayed and the change is not made.
Also, an "expires" value of -1 (never) cannot be entered.

Note You need to log in before you can comment on or make changes to this bug.