Bug 440603 - vlan on bridge interface not upped at boot
vlan on bridge interface not upped at boot
Status: CLOSED DUPLICATE of bug 462095
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: initscripts (Show other bugs)
5.1
i386 Linux
low Severity medium
: rc
: ---
Assigned To: initscripts Maintenance Team
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-04 06:48 EDT by ariev3
Modified: 2009-03-19 16:39 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-19 16:39:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description ariev3 2008-04-04 06:48:56 EDT
Description of problem:

initscripts-8.45.17.EL-1

A vlan defined on top of a bridge is not correctly initiated on boot.

cd /etc/sysconfig/network-scripts/
cat ifcfg-br0
 DEVICE=br0
 ONBOOT=yes
 BOOTPROTO=none
 TYPE=Bridge
 brctl stp br0 on

cat ifcfg-br0.3 
 DEVICE=br0.3
 BOOTPROTO=static
 TYPE=Ethernet
 ONBOOT=yes
 IPADDR=172.16.128.126
 NETMASK=255.255.255.224
 BROADCAST=172.16.128.127
 NETWORK=172.16.128.96



How reproducible:
upon each reboot

Actual results:
Delaying initialisation

Expected results:
up


Additional info:
in /etc/sysconfig/network-scripts/ifup, line 65, change
if [[ "${DEVICE}" =~ '^(eth|bond)[0-9]+\.[0-9]{1,4}$' ]]; then

into

if [[ "${DEVICE}" =~ '^(eth|bond|br)[0-9]+\.[0-9]{1,4}$' ]]; then

fixes it
Comment 1 Bill Nottingham 2008-04-04 10:00:36 EDT
Bridge devices aren't necessarily only named br*, so that's not good enough.
Comment 2 Bill Nottingham 2009-03-19 16:39:43 EDT

*** This bug has been marked as a duplicate of bug 462095 ***

Note You need to log in before you can comment on or make changes to this bug.