Bug 440629 - there should be %{?dist} instead of %{dist} in the *.spec on the Release: line
there should be %{?dist} instead of %{dist} in the *.spec on the Release: line
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: SDL (Show other bugs)
5.2
All Linux
low Severity low
: rc
: ---
Assigned To: Petr Pisar
BaseOS QE - Apps
: EasyFix
Depends On:
Blocks: 440605
  Show dependency treegraph
 
Reported: 2008-04-04 07:08 EDT by Jan Hutař
Modified: 2013-04-15 04:55 EDT (History)
2 users (show)

See Also:
Fixed In Version: SDL-1.2.10-9.el5
Doc Type: Bug Fix
Doc Text:
Cause `dist' macro in Release tag has not been expanded conditionally. Consequence Building SDL package in environments without defined dist macro could cause building failures or warnings. Spec file does not conform to packaging guidelines. Fix `dist' macro is expanded conditionally by using conditional expansion. Result Building proceeds without warnings about undefined macro. The macro is expanded to empty string if not defined in build environment.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-31 05:15:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jan Hutař 2008-04-04 07:08:22 EDT
Description of problem:
There should be "%{?dist}" instead of "%{dist}" in the *.spec file on the 
"Release:" line.


Version-Release number of selected component (if applicable):
SDL-1.2.10-8.el5


Additional info:
http://fedoraproject.org/wiki/Packaging/DistTag
Comment 1 Phil Knirsch 2008-05-05 08:10:30 EDT
Proposing for RHEL-5.3 and granting Devel ACK.

Read ya, Phil
Comment 3 Phil Knirsch 2008-05-14 10:29:34 EDT
Proposing bug for RHEL-5.3 FasTrack.

Read ya, Phil
Comment 4 RHEL Product and Program Management 2008-05-14 10:43:27 EDT
This bugzilla was reviewed by QE as a non-FasTrack request.
It has since been proposed for FasTrack. The qa_ack has 
been reset. QE needs to re-review this bugzilla for FasTrack.
Comment 15 Petr Pisar 2011-08-26 04:44:10 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause
    `dist' macro in Release tag has not been expanded
    conditionally.
Consequence
    Building SDL package in environments without defined dist
    macro could cause building failures or warnings. Spec file
    does not conform to packaging guidelines.
Fix
    `dist' macro is expanded conditionally by using conditional
    expansion.
Result
    Building proceeds without warnings about undefined macro.
    The macro is expanded to empty string if not defined in
    build environment.
Comment 18 errata-xmlrpc 2011-08-31 05:15:49 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-1233.html

Note You need to log in before you can comment on or make changes to this bug.