Bug 440638 - The installation is stopped without error message if no cd-rom/dvd defined
The installation is stopped without error message if no cd-rom/dvd defined
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virt-manager (Show other bugs)
5.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Cole Robinson
Virtualization Bugs
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-04 07:21 EDT by Adam Stokes
Modified: 2010-10-22 19:45 EDT (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2008-0480
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 13:29:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to throw a proper error if nothing is entered in cdrom field (844 bytes, patch)
2008-04-08 14:20 EDT, Cole Robinson
no flags Details | Diff

  None (edit)
Description Adam Stokes 2008-04-04 07:21:29 EDT
Description of problem:
We get no reply from virt-manager when we select [CD-ROM or DVD] as
 installation media without filling in the path of install media.
 So, we cannot continue to install.

Version-Release number of selected component (if applicable):
virt-manager 0.5.3

How reproducible:
100%

Steps to Reproduce:
  1. Start virt-manager.
 2. Click [New] button.
 3. Select [Fully Virtualized], and click [Forward] button.
 4. Select [CD-ROM or DVD] at 'Locating installation media',
    and click [Forward] button without filling in the path of install media.

Actual Results
 We cannot proceed the installation.
 
Expected Results
 The virt-manager says the error message (like 'CD-ROM Path Error'),
 if we must specify the path of install media.
 And, we can solve the error and proceed the installation.

Additional info:
https://www.redhat.com/archives/et-mgmt-tools/2008-March/msg00148.html

commit
http://hg.et.redhat.com/virt/applications/virt-manager--devel?cs=e6972a659499
Comment 1 RHEL Product and Program Management 2008-04-04 07:33:39 EDT
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.
Comment 3 Cole Robinson 2008-04-07 13:19:25 EDT
This is a regression, but it is only a matter of polish. Previously the user
would see an error message along the lines of "you need to enter data in X", now
no error is shown. The end result is the same though (can't proceed forward in
the install wizard).

The patch is simple, non-intrusive, and easy to test, so it won't hurt to pull
this in.
Comment 4 Cole Robinson 2008-04-08 14:20:52 EDT
Created attachment 301679 [details]
Patch to throw a proper error if nothing is entered in cdrom field
Comment 6 Cole Robinson 2008-04-08 15:54:54 EDT
Fixed in latest virt-manager:

$ brew latest-pkg dist-5E-qu-candidate virt-manager
Build                                     Tag                   Built by
----------------------------------------  --------------------  ----------------
virt-manager-0.5.3-7.el5                  dist-5E-qu-candidate  crobinso
Comment 8 Gurhan Ozen 2008-04-15 04:59:26 EDT
virt-manager-0.5.3-7.el5 fixes it.
Comment 10 errata-xmlrpc 2008-05-21 13:29:17 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0480.html

Note You need to log in before you can comment on or make changes to this bug.