This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 440650 - unopkg runs 'mktemp --tmpdir' which fails
unopkg runs 'mktemp --tmpdir' which fails
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ooolatex
  Show dependency treegraph
 
Reported: 2008-04-04 08:25 EDT by Alex Lancaster
Modified: 2008-07-02 02:59 EDT (History)
1 user (show)

See Also:
Fixed In Version: 2.3.0-6.14.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-22 18:41:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alex Lancaster 2008-04-04 08:25:57 EDT
I first installed the new release of openoffice.org in updates-testing:

https://admin.fedoraproject.org/updates/F8/FEDORA-2008-2552

Then attempted to install the voikko extension, got this:

$ sudo yum install openoffice.org-voikko

<snip>

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Installing:
 openoffice.org-voikko   i386       2.1-3.fc8        updates            51 k
Installing for dependencies:
 libmalaga               i386       7.11-1.fc8       updates            85 k
 libvoikko               i386       1.6-1.fc8        updates            39 k
 malaga                  i386       7.11-1.fc8       updates           285 k
 malaga-suomi-voikko     i386       1.0-1.fc8        updates           1.2 M

Transaction Summary
=============================================================================
Install      5 Package(s)         
Update       0 Package(s)         
Remove       0 Package(s)         

Total download size: 1.6 M
Is this ok [y/N]: y
Downloading Packages:
Downloading DeltaRPMs:
Rebuilding rpms from deltarpms
(1/5): libmalaga-7.11-1.f 100% |=========================|  85 kB    00:00     
(2/5): openoffice.org-voi 100% |=========================|  51 kB    00:00     
(3/5): libvoikko-1.6-1.fc 100% |=========================|  39 kB    00:00     
(4/5): malaga-suomi-voikk 100% |=========================| 1.2 MB    00:05     
(5/5): malaga-7.11-1.fc8. 100% |=========================| 285 kB    00:00     
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing: libmalaga                    ######################### [1/5] 
  Installing: malaga                       ######################### [2/5] 
  Installing: malaga-suomi-voikko          ######################### [3/5] 
  Installing: libvoikko                    ######################### [4/5] 
  Installing: openoffice.org-voikko        ######################### [5/5] 
/bin/mktemp: invalid option -- -
Usage: mktemp [-V] | [-dqtu] [-p prefix] [template]

Installed: openoffice.org-voikko.i386 0:2.1-3.fc8
Dependency Installed: libmalaga.i386 0:7.11-1.fc8 libvoikko.i386 0:1.6-1.fc8
malaga.i386 0:7.11-1.fc8 malaga-suomi-voikko.i386 0:1.0-1.fc8
Complete!

Not sure if the mktemp call is fatal or not.

Version: 2.1-3.fc8
Comment 1 Ville-Pekka Vainio 2008-04-04 17:27:56 EDT
Thanks for reporting this, I'm also CCing Caolan.

I don't think the mktemps in oo.o-voikko are to blame here, as they do
"TMP_HOME="$(mktemp -t -d %{name}.XXXXXX)" || exit 1", so shouldn't the whole
RPM transaction fail if that mktemp fails?

I also added some echo statements to the RPM scripts to get an idea on what's
happening.

When installing, I get this:
Running Transaction
leaving pre
  Installing: openoffice.org-voikko        ######################### [1/1] 
post
will run mktemp -t -d openoffice.org-voikko.XXXXXX
/tmp/openoffice.org-voikko.Lw6423
/bin/mktemp: invalid option -- -
Usage: mktemp [-V] | [-dqtu] [-p prefix] [template]
leaving post

When removing, I get this:
Running Transaction
preun
will run mktemp -t -d openoffice.org-voikko.XXXXXX
/tmp/openoffice.org-voikko.wR6599
/bin/mktemp: invalid option -- -
Usage: mktemp [-V] | [-dqtu] [-p prefix] [template]
leaving preun
  Erasing   : openoffice.org-voikko        ######################### [1/1]

I think this also shows that the mktemp call in oo.o-voikko succeeds, as I can
print the path to the temp dir.

I guess the bug may be in openoffice.org itself, Caolan, could you take a look
at this as well?
Comment 2 Ville-Pekka Vainio 2008-04-04 18:03:01 EDT
I think I found the cause. F-8 and F-9 have different versions of the coreutils
package and mktemp's command line option handling has changed between those
versions.

The script /usr/lib/openoffice.org/program/unopkg does "/bin/mktemp -d --tmpdir
unoinstall.XXXXXX" and --tmpdir works on F-9 but not on F-8. I guess -t should
be used in F-8.

I'll try to reassign this bug to Caolan, let's see if I have enough bugzilla
skills for it ;)
Comment 3 Alex Lancaster 2008-04-05 06:27:39 EDT
I'm hit with the same issue on F-8 when packaging the extension ooolatex: bug
#441027
Comment 4 Alex Lancaster 2008-04-05 06:28:21 EDT
That would be bug 441027
Comment 5 Caolan McNamara 2008-04-05 09:01:23 EDT
ah!, good thing I did some test versions at least.

Builds in progress
Comment 6 Fedora Update System 2008-04-08 14:40:59 EDT
openoffice.org-2.3.0-6.13.fc8 has been submitted as an update for Fedora 8
Comment 7 Fedora Update System 2008-04-17 14:38:46 EDT
openoffice.org-2.3.0-6.14.fc8 has been submitted as an update for Fedora 8
Comment 8 Fedora Update System 2008-04-22 18:41:04 EDT
openoffice.org-2.3.0-6.14.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Yolkfull Chow 2008-07-02 02:59:31 EDT
Had verified this problem could not be reproduced on F9.

Note You need to log in before you can comment on or make changes to this bug.