This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 440659 - search should cancel current search operation
search should cancel current search operation
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Robin Norwood
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-04 08:58 EDT by Andrew Farris
Modified: 2008-04-07 22:00 EDT (History)
2 users (show)

See Also:
Fixed In Version: PackageKit-0.1.11-1.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-07 22:00:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
showing multiple running searches (120.00 KB, image/png)
2008-04-04 08:58 EDT, Andrew Farris
no flags Details
pk-searches-canceling.txt (416.29 KB, text/plain)
2008-04-07 22:00 EDT, Andrew Farris
no flags Details

  None (edit)
Description Andrew Farris 2008-04-04 08:58:35 EDT
Description of problem:
The packagekit pk-application install UI should cancel any prior search
operation when a new one is started.  If you currently enter a search term and
hit enter, then immediately change the search term and hit enter, and repeat
this, then multiple searches will be queued which will all complete one at a
time (or it may just lock up...).

It is not necessary to attempt to finish a search operation if a new one was
started, because it will have nowhere to be displayed (this is not a tabbed or
multiple view application).

Version-Release number of selected component (if applicable):
PackageKit-0.1.10-1.fc9

Steps to Reproduce:
1. start several searches in a row before they are able to complete
Comment 1 Andrew Farris 2008-04-04 08:58:35 EDT
Created attachment 300425 [details]
showing multiple running searches
Comment 2 Richard Hughes 2008-04-04 10:14:19 EDT
Does this still happen if you use the packages here:
http://people.freedesktop.org/~hughsient/fedora/9/i386/

Thanks.
Comment 3 Andrew Farris 2008-04-04 23:39:30 EDT
No, it looks like I cannot cause this with:
PackageKit-0.1.11-0.639.20080404git.fc9.hughsie.i386

At most I see two operations at once shown in the context menu.  This was most
noticeable on my x86_64 virtual machine which runs everything slower and may
still react a bit less quickly.
Comment 4 Andrew Farris 2008-04-04 23:48:18 EDT
My screenshot above was only showing 2 entries, but I had seen up to 5 of them
left over 'waiting for..', so now seeing max 2 is different at least.
Comment 5 Richard Hughes 2008-04-07 05:08:23 EDT
How are you managing to get two queued searches? Do you have two instances of
gpk-application open?
Comment 6 Andrew Farris 2008-04-07 05:21:00 EDT
Nope, open one instance, then start a search, change the search term, hit enter, change the search term, 
hit enter, etc.  If the network happens to stall just a little bit (i.e. the search takes more than a few 
seconds, most do) then the searches start to stack up.

I found this when I typed the search term wrong several times accidentally, fat fingering my searches a 
few times.
Comment 7 Andrew Farris 2008-04-07 05:24:56 EDT
Note that it was actually slowing down the final result, not just having multiple entries show up in the 
context menu on the panel applet.  On my x86_64 virtual machine I was seeing the 5 or 6 entries, which 
then each disappear one at a time (finished searching) until the final search would run and show me the 
results.  As I said with your test repo (on my i686 machine) I don't see this happen, instead they appear to 
be trying to cancel and run only the last entered search.  I don't know if its due to the network/machine 
performance difference or if there is a code difference that should show that result.
Comment 8 Richard Hughes 2008-04-07 05:37:56 EDT
Hmm. Could you please attach the *complete* output of:

gpk-application --verbose

when you manage to get the multiple queue. Thanks.
Comment 9 Andrew Farris 2008-04-07 21:58:05 EDT
Ok I can't reproduce this on PK-0.1.11-1, either x86_64 or i386.  There are 2
entries shown in the applet context menu only long enough to notice if I try to
change the search term and immediately click the applet to see the menu.

Repeated searches appear to be canceling prior searches quickly now.  I'm
attaching a long output of things working correctly.. except for the broken
access to database several times at the beginning, then after refresh
application list it starts working.

I'm going to close this as it seems to be working for now, but attachment coming
anyway.
Comment 10 Andrew Farris 2008-04-07 22:00:04 EDT
Created attachment 301590 [details]
pk-searches-canceling.txt

Note You need to log in before you can comment on or make changes to this bug.