Bug 44097 - logging doesnt function properly after upgrade
logging doesnt function properly after upgrade
Status: CLOSED NEXTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: sysklogd (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
Brian Brock
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-11 00:01 EDT by Henri Schlereth
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-08 11:07:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Henri Schlereth 2001-06-11 00:01:45 EDT
Description of Problem:
Logging doesnt function properly after upgrade from 7.0 -> 7.1

How Reproducible:
Upgrade a 7.0 box with ppp to 7.1  The new syslog.conf is set to rpmnew and
it fails to read/use properly the old one.

Steps to Reproduce:
1. see above

Actual Results:
Because I could no longer collect connect time scripts I thought there was
either something
wrong with ppp or initscripts. Once I move rpmnew over and added my custom
entries
and restarted syslog it restarted syslog everything started logging again.

A specific example was that I had local3.* going to /var/log/tcp-log
(tcplogd utility)
that only was logging to tcp-log and not to messages as well and ppp wasnt
logging
at all.

Suggest switch from rpmnew to making the old syslog.conf to an rpmorig or
rpmsave. It
would have saved me several days of research and upgrading to rawhide
initscripts and pppd.
Comment 1 Bill Nottingham 2001-07-09 00:20:28 EDT
No, because there's really no reason for it to fail on the old file - the
format hasn't changed. Do you know which part it was choking on?
Comment 2 Henri Schlereth 2001-07-09 01:08:16 EDT
No, I really dont know which part it chokes on. It merely stops logging the
connection/chat
scripts after about 6 days. My current syslog shows logging from July 1 to July
6th and
then it merely starts logging "unable to locate module ppp0" and does the
connection
"invisibly". I know that everything is functioning properly because a.) I still
have access
and b.) the ppp.log is still functioning.
Comment 3 Henri Schlereth 2005-12-08 11:06:05 EST
This is such an ancient bug, I was surprised that it was still open.
I don't know if there ever was a solution but I am closing it since RH is all
the way into Fedore Core 4 and 5 is due out soon.

Note You need to log in before you can comment on or make changes to this bug.