Bug 440976 - partition resize causes traceback in Fedora 9 beta
partition resize causes traceback in Fedora 9 beta
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-04 15:07 EDT by Paul Walmsley
Modified: 2008-04-04 15:27 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-04 15:27:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda python stack trace (714 bytes, text/plain)
2008-04-04 15:25 EDT, Paul Walmsley
no flags Details

  None (edit)
Description Paul Walmsley 2008-04-04 15:07:53 EDT
Description of problem:
In Fedora 9 beta, selecting "Resize existing partition and create default layout
in free space" causes a Python crash and stack backtrace on a stock IBM Thinkpad
T61 8897CTO with factory partition layout.  First partition is recovery
partition; second is Windows Vista Home Basic.  Both partitions are NTFS.

The partition selection dialog appears in the top left corne

Version-Release number of selected component (if applicable):
11.4.0.55

How reproducible:
See above.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Paul Walmsley 2008-04-04 15:24:42 EDT
more information:

When "Resize existing partition ..." is selected, and the "Next" button is
pressed, a dialog appears in the top left corner of the screen, without the
window frame.  It reads: "Which partition would you like to resize to make room
for your installation?" and displays a blank drop-down.  Below that, it reads
"Resize target" along with a corresponding drop-down, which reads "1".  

A stack trace is immediately generated, however, without any opportunity to
interact with this window.  I've attached the Python traceback, which I had to
copy by hand due to other Anaconda bugs.  It does not include the Anaconda dump
due to sheer size, but if there is specific information you need from the
Anaconda portion of the dump, please let me know and I will provide it.  
Comment 2 Paul Walmsley 2008-04-04 15:25:24 EDT
Created attachment 301327 [details]
anaconda python stack trace
Comment 3 Jeremy Katz 2008-04-04 15:27:02 EDT
Fixed this up last week and it should be working with last week's snapshot

Note You need to log in before you can comment on or make changes to this bug.