Bug 440982 - slideshow backgrounds "jump", clobber top panel
slideshow backgrounds "jump", clobber top panel
Status: CLOSED DUPLICATE of bug 441219
Product: Fedora
Classification: Fedora
Component: compiz (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Kristian Høgsberg
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-04 15:41 EDT by Tom London
Modified: 2008-05-01 20:12 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-01 20:12:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom London 2008-04-04 15:41:32 EDT
Description of problem:
Selecting a slideshow background jumps/jitters, and appears to overwrite the top
panel before sliding down.

With the "Wave" background this happens almost exactly every 70 seconds.

Version-Release number of selected component (if applicable):
gnome-desktop-2.22.0-5.fc9.i386 (and prior)

How reproducible:
Every time

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Matthias Clasen 2008-04-04 21:54:35 EDT
Are you using compiz ?
Comment 2 Tom London 2008-04-05 12:27:47 EDT
Yeah, sorry for the weak report.

Here is a better report: Thinkpad X60, intel 945GM/GMS, compiz.  Compiz running
with '--indirect-rendering'.

No messages in either ~/.xsession-errors or /var/log/Xorg.0.log that appear
relevant.

Have been getting these lately however:
failed to create drawable
failed to create drawable
failed to create drawable
failed to create drawable

in .xsession-errors, but I get these with PNG background too. (Appear to get
them when a new window/menu/popup is displayed).

Comment 3 Matěj Cepl 2008-04-09 08:10:51 EDT
I don't see it here, but no idea how to triage this more.
Comment 4 Tom London 2008-04-09 09:32:37 EDT
Uhhh...

Here are version of compiz I'm running (I think Rawhide):

[tbl@localhost ~]$ rpm -qa compiz\*
compizconfig-backend-gconf-0.7.2-1.fc9.i386
compiz-gnome-0.7.2-3.fc9.i386
compiz-fusion-extras-0.7.2-2.fc9.i386
compiz-fusion-extras-gnome-0.7.2-2.fc9.i386
compiz-0.7.2-3.fc9.i386
compizconfig-python-0.7.2-1.fc9.i386
compiz-manager-0.6.0-7.fc9.noarch
compiz-fusion-gnome-0.7.2-2.fc9.i386
compiz-fusion-0.7.2-2.fc9.i386
[tbl@localhost ~]$ 

This happens with every "slideshow" background.

In fact, even selecting a JPEG or PNG background clobbers the top panel.  I have
to "rotate the cube" to restore it.  So maybe the "slideshow" angle is not the
primary issue.

What more can I do?
Comment 5 Tom London 2008-04-09 10:17:13 EDT
OK.  I may have figured this out..... This may have something to do with the way
I start compiz, gnome-sessions and indirect rendering..... 

I have my session 'setup' to start compiz on gnome login. Here is the line in
.gnome2/session that I was using:

9,CloneCommand=compiz --indirect-rendering --sm-client-id --replace glib gconf 

Here is what I did:

1. I turned off desktop effects and saved the session, and logged in again. 
Session started without compiz, and I had no problems with 'slideshow' wave
background.

2. I started 'Compiz Fusion Icon' (I have it configured to use 'indirect
rendering'), and compiz started.  Within a few seconds, I started seeing jumpy
flickering as the background appeared to be refreshed, but the top panel was OK.

3. I restored the 'compiz .gnome2/session file', but I changed the compiz lines to:
9,CloneCommand=/home/tbl/bin/run-compiz.sh
9,RestartCommand=/home/tbl/bin/run-compiz.sh

where run-compiz.sh is:
#!/bin/bash

LIBGL_ALWAYS_INDIRECT=1 compiz --indirect-rendering --sm-client-id --replace
glib gconf

This adds the 'LIBGL_ALWAYS_INDIRECT=1' to the call of compiz.

This changes 2 things: first, the flickery, jumpy, overwrite the top panel seems
to have vanised; and second, I no longer seem to be getting

failed to create drawable
failed to create drawable

messages in ~/.xsession-errors.

Is it likely that I just botched the 'compiz startup'?  Am I doing this wrong?

Is the above a possible explanation?
Comment 6 Tom London 2008-04-09 12:06:52 EDT
Uhhh.... above does not cover it.....

The monitor in my work office has the jitters and overwrites of the top panel
even with the changes described in #5...

Sorry.

[The changes do eliminate the "failed to create drawable" messages in
.xsession-errors however.]
Comment 7 Tom London 2008-04-18 12:36:46 EDT
Continue to have this issue with:

[tbl@localhost ~]$ rpm -qa compiz\* mesa\*
compizconfig-backend-gconf-0.7.2-1.fc9.i386
compiz-gnome-0.7.2-3.fc9.i386
compiz-fusion-extras-0.7.2-2.fc9.i386
mesa-libGLU-devel-7.1-0.28.fc9.i386
mesa-libOSMesa-7.1-0.28.fc9.i386
mesa-libGLU-7.1-0.28.fc9.i386
compiz-fusion-extras-gnome-0.7.2-2.fc9.i386
mesa-libOSMesa-devel-7.1-0.28.fc9.i386
compiz-0.7.2-3.fc9.i386
mesa-libGL-devel-7.1-0.28.fc9.i386
mesa-libGL-7.1-0.28.fc9.i386
compizconfig-python-0.7.2-1.fc9.i386
compiz-manager-0.6.0-7.fc9.noarch
compiz-fusion-gnome-0.7.2-2.fc9.i386
compiz-fusion-0.7.2-2.fc9.i386
[tbl@localhost ~]$ 

Surprisingly, it seems to behave differently on different monitors.

I could swear it doesn't 'jitter' with my old MEL monitor, but it does with my
HP monitor.

Am I smoking too many Fedora bits? ;)
Comment 8 Harald Hoyer 2008-04-18 14:52:29 EDT
flickers for me with compiz, too. but more than every 70s.
Comment 9 Behdad Esfahbod 2008-05-01 20:12:11 EDT

*** This bug has been marked as a duplicate of 441219 ***

Note You need to log in before you can comment on or make changes to this bug.